Find the answer to your Linux question:
Results 1 to 6 of 6
Ok, so at my work we're considering migrating to SLES 10 w/ OES2 from our current netware servers. However, they want a demonstration of how it works, what it looks ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    10

    SLES 10/OES 2 Problem


    Ok, so at my work we're considering migrating to SLES 10 w/ OES2 from our current netware servers. However, they want a demonstration of how it works, what it looks like, etc, etc. So that's what I'm working on, trying to get it to work. I've gotten SLES 10 on there fine and it works like a charm, however, they want to see the Novell side, and to the best I can tell, OES 2 has all the little Novell tools (NDS, etc). So I have OES 2 and have been trying to upgrade it, and it reads the disc fine, but whenever I select all Novell apps to add in, it keeps bringing up an error message about dependency issues, and in the end, I can't install anything. Has anyone done this before or have any experience working with SLES or OES? I'm not even 100% sure I'm doing things right, but from everything I've read, it seems I am. Thanks in advance,

    Tyler D. Franklin

  2. #2
    Linux Newbie athlon_crazy's Avatar
    Join Date
    Sep 2007
    Location
    Malaysia
    Posts
    132
    Patch it dude! Are you working on SLES 10 only or SLES 10 SP1?

    1) Check your version first ~$: cat /etc/*-release

    SUSE Linux Enterprise Server 10 (i586)
    VERSION = 10
    PATCHLEVEL = 1
    LSB_VERSION="core-2.0-noarch:core-3.0-noarch:core-2.0-ia32:core-3.0-ia32"
    Novell Open Enterprise Server 2 (i586)
    VERSION = 2
    BUILD = FCS

    2) If confirm SLES 10 SP1, install OES 2 from terminal ~$:yast
    -> Add-on Product - > OES 2

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    10
    Ok, sorry, yes, I did install SP1 and have updated with everything out there. Still, it gives me all the dependency errors. I'll post a copy of all the dependency errors that I'm getting below.

    Just to be a little more detailed about it, I'm trying to install the Novell Applications that come with OES 2 (edirectory, NDS, everything). A strange thing about this is that it doesn't actually list those services in the "patterns" selection, I have to go under "package groups" then to networking and Novell to see the services. And that's where I've been selecting them to install from and I get the dependency issues. Also, when I go to add-on and accept the agreement for OES 2, it says that the product is already installed or scheduled for install. I just really have no idea what the problem is. Maybe I should just wipe the drive and start over from scratch. This is just a test server and doesn't host anything important, so whatever the easiest way to get the solution, I'm willing to try. Thanks for all the help.

    Here's the error list I get when trying to install the Novell products from OES2.


    #### YaST2 conflicts list - generated 2008-01-28 05:36:03 ####

    CASA_auth_token_svc-1.7.1407-6.noarch[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of CASA for CASA_auth_token_svc-1.7.1407-6.noarch[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install CASA_auth_token_svc
    ( ) Ignore this requirement just here
    ifolder3-tsa-3.6.0.7261.1-2.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libsmsut.so.0 for ifolder3-tsa-3.6.0.7261.1-2.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install ifolder3-tsa
    ( ) Ignore this requirement just here
    novell-edirectory-tsands-8.8.2-70.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libndssdk.so.1 for novell-edirectory-tsands-8.8.2-70.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-edirectory-tsands
    ( ) Ignore this requirement just here
    novell-imanager-2.7-75.noarch[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-nmasclient for novell-imanager-2.7-75.noarch[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-imanager
    ( ) Ignore this requirement just here
    novell-iprint-iprntman-6.0.20070912-2.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-filesystem for novell-iprint-iprntman-6.0.20070912-2.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-iprint-iprntman
    ( ) Ignore this requirement just here
    novell-iprint-migration-6.0.20070922-2.noarch[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-ncpserv-tools for novell-iprint-migration-6.0.20070922-2.noarch[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-iprint-migration
    ( ) Ignore this requirement just here
    novell-kerberos-authentication-1.5-31.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-kerberos-authentication-1.5-31.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-kerberos-authentication
    ( ) Ignore this requirement just here
    novell-kerberos-password-agent-1.5-31.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-ntls for novell-kerberos-password-agent-1.5-31.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-kerberos-password-agent
    ( ) Ignore this requirement just here
    novell-kerberos-server-base-1.5-31.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-kerberos-server-base-1.5-31.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-kerberos-server-base
    ( ) Ignore this requirement just here
    novell-kerberos-utilities-1.5-31.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-kerberos-utilities-1.5-31.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-kerberos-utilities
    ( ) Ignore this requirement just here
    novell-ncpenc-5.1.2-11.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libntls.so.2(OPENSSL_VERSION_NUMBER) for novell-ncpenc-5.1.2-11.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-ncpenc
    ( ) Ignore this requirement just here
    novell-ncpserv-nrm-2.0.1-3.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-libncputil for novell-ncpserv-nrm-2.0.1-3.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-ncpserv-nrm
    ( ) Ignore this requirement just here
    novell-NDSbase-8.8.2-70.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libndssdk.so.1 for novell-NDSbase-8.8.2-70.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-NDSbase
    ( ) Ignore this requirement just here
    novell-NDSimon-8.8.2-31.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libndssdk.so.1 for novell-NDSimon-8.8.2-31.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-NDSimon
    ( ) Ignore this requirement just here
    novell-NDSrepair-8.8.2-26.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libndssdk.so.1 for novell-NDSrepair-8.8.2-26.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-NDSrepair
    ( ) Ignore this requirement just here
    novell-NDSserv-8.8.2-70.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libxi18n.so for novell-NDSserv-8.8.2-70.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-NDSserv
    ( ) Ignore this requirement just here
    novell-nmas-3.2.0-44.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-NDSmasv for novell-nmas-3.2.0-44.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-nmas
    ( ) Ignore this requirement just here
    novell-NOVLembox-8.8.2-29.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libsal.so.1 for novell-NOVLembox-8.8.2-29.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-NOVLembox
    ( ) Ignore this requirement just here
    novell-NOVLice-8.8.2-70.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-NOVLice-8.8.2-70.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-NOVLice
    ( ) Ignore this requirement just here
    novell-NOVLsnmp-8.8.2-35.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libndssdk.so.1 for novell-NOVLsnmp-8.8.2-35.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-NOVLsnmp
    ( ) Ignore this requirement just here
    novell-NOVLsubag-8.8.2-35.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-NOVLsubag-8.8.2-35.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-NOVLsubag
    ( ) Ignore this requirement just here
    novell-npkiapi-3.3.0-24.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-npkiapi-3.3.0-24.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-npkiapi
    ( ) Ignore this requirement just here
    novell-npkiserver-3.3.0-27.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-npkiserver-3.3.0-27.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-npkiserver
    ( ) Ignore this requirement just here
    novell-npkit-3.3.0-23.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-npkit-3.3.0-23.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-npkit
    ( ) Ignore this requirement just here
    novell-nrm-2.0-52.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-nrm-2.0-52.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-nrm
    ( ) Ignore this requirement just here
    novell-oes-install-1.6.0-24.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libldapsdk.so.0 for novell-oes-install-1.6.0-24.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-oes-install
    ( ) Ignore this requirement just here
    novell-sms-1.1.6-48.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libsmsut.so.0 for novell-sms-1.1.6-48.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-sms
    ( ) Ignore this requirement just here
    novell-sss-3.4.1-22.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libndssdk.so.1 for novell-sss-3.4.1-22.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-sss
    ( ) Ignore this requirement just here
    novell-web-base-2.2.0-21.noarch[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-filesystem for novell-web-base-2.2.0-21.noarch[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-web-base
    ( ) Ignore this requirement just here
    novell-welcomepage-2.2.0-58.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-web-config for novell-welcomepage-2.2.0-58.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install novell-welcomepage
    ( ) Ignore this requirement just here
    openldap2-2.3.32-0.23.i586 conflicts with other resolvables
    openldap2-2.3.32-0.23.i586 conflicts with: novell-NDSserv-8.8.2-70.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) delete openldap2
    ( ) do not install novell-NDSserv
    ( ) Ignore this conflict of openldap2
    pattern:directory_server-10-51.35.i586 cannot be installed due to missing dependencies
    There are no installable providers of openldap2 for pattern:directory_server-10-51.35.i586
    Conflict Resolution:
    ( ) delete directory_server
    ( ) Ignore this requirement just here
    quickfinder-engine-3.0.0-39.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of libnetlnx.so.1 for quickfinder-engine-3.0.0-39.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install quickfinder-engine
    ( ) Ignore this requirement just here
    quickfinder-server-5.0.0-46.i586[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of CASA for quickfinder-server-5.0.0-46.i586[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install quickfinder-server
    ( ) Ignore this requirement just here
    yast2-novell-common-2.13.8-74.noarch[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of oes-release for yast2-novell-common-2.13.8-74.noarch[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install yast2-novell-common
    ( ) Ignore this requirement just here
    yast2-novell-schematool-2.13.1-33.noarch[Novell Open Enterprise Server 2] cannot be installed due to missing dependencies
    There are no installable providers of novell-ntls for yast2-novell-schematool-2.13.1-33.noarch[Novell Open Enterprise Server 2]
    Conflict Resolution:
    ( ) do not install yast2-novell-schematool
    ( ) Ignore this requirement just here

    #### YaST2 conflicts list END ###

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie athlon_crazy's Avatar
    Join Date
    Sep 2007
    Location
    Malaysia
    Posts
    132
    Could you identify which packages already installed?

    The best way, just reinstall SLES 10 SP1 + add-on for OES2...

  6. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    10
    Ok, yea, at first I only installed the packages I was looking at using, but when I got the dependency problems, I just installed everything from SLES10, 100%, and still got the same problem, however, I think you're right, I just need to do a reinstall and do the add-on at the beginning and see what happens. I'll try that today or tomorrow and post my results.

  7. #6
    Just Joined!
    Join Date
    Jan 2008
    Posts
    10

    I might be an idiot...

    Well, I think I figured out what my problem was, finally.

    When i went to reinstall, I put the OES 2 disk in and selected it as an add-on product and was still getting the error messages, so I hopelessly was looking through the binder of software and found another OES 2 disk. I popped it in and voila! Turns out, the disk I was using was the x86 and the one that works is i386. Go figure, complicated Novell. I'm still installing, but at least it allowed me to select Novell Services and brought them up under the packages group. I'll post progress after I finish installing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •