Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I installed Ubuntu 7.10 Server edition and selected to create a LAMP, DNS, OpenSSH, Mail and Print server on install. Then whilst everything was default, I installed webmin. Whilst ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    1

    Trouble installing Webmin on Ubuntu 7.10 server ed.


    Hi,

    I installed Ubuntu 7.10 Server edition and selected to create a LAMP, DNS, OpenSSH, Mail and Print server on install.

    Then whilst everything was default, I installed webmin.

    Whilst the apache and mysql modules seem to be installed fine, when I click to view the PHP configuration for just one example, it just says that it cannot load the module. The option to click 'install' seems to be missing, I was expecting to click on the link, and then be able to view the php.ini file, but it seems it can't find the installation of PHP.

    It has been this way for two days now and despite reading many tutorials on setting up the combination, none seem to have had these problems at all.

    Any advice would be greatly appreciated, as I'm unsure what to try next.

    Many thanks

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    hmm, I don't even see a link for php in my webmin (running debian)

    first is php installed and working?
    create in your www folder phpinfo.php and put this in it
    Code:
    <?php
    
    phpinfo ();
    
    ?>
    now hit that page from a web browser. if you get lots of php info then its working.

    an alternative way of editing the php.ini file in webmin would be to go to custom commands, and then create a new file editor and you can edit the php.ini

  3. #3
    Linux Newbie athlon_crazy's Avatar
    Join Date
    Sep 2007
    Location
    Malaysia
    Posts
    132
    Did you configured your php "module config"?

    1) slocate your php.ini
    2) configure actual path to php.ini in your php "module config"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •