Find the answer to your Linux question:
Results 1 to 2 of 2
Hi I am using CentOS 4 machine..trying to install MySQL for python to setup a boinc project.. During the building process I am getting this error..I have even set the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3

    MySQL python installation


    Hi

    I am using CentOS 4 machine..trying to install MySQL for python to setup a boinc project..
    During the building process I am getting this error..I have even set the LD_lIBRARY_PATH to /usr/local/lib where the libmysqlclient.so file is present..

    ./python -E ./setup.py build
    ./python: error while loading shared libraries: libmysqlclient.so.15: cannot open shared object file: No such file or directory

    I tried installing both the ways..
    1. downloaded mysql for the python present and builded mysql..
    2. downloaded both MySQL-python and Python and then builded both the files together..using the commands given in the link..
    PythonMysql - BOINC - Trac

    But getting the same error..
    Please help me out asap!!

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    6
    It sounds quite dirty, heck, it is dirty, but I would try making a (hope no experienced users shout at me) symlink called libmysqlclient.so.15 ...
    Also, check this out,
    Postfix broken after mysql upgrade
    one of the guys out there said that
    Code:
    ln -s /usr/lib/mysql/libmysqlclient.so.15.0.0 usr/lib/libmysqlclient.so.15
    did the trick
    Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •