Find the answer to your Linux question:
Results 1 to 2 of 2
Hi All! I am trying to update my squid and squidguard install. I have them working on an OLD server that is due to be decommissioned. My new setup is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    4

    SquidGuard and Berkeley DB Woes


    Hi All!

    I am trying to update my squid and squidguard install. I have them working on an OLD server that is due to be decommissioned.

    My new setup is on a RHEL 5 Server with 2.6.STABLE6, SquidGuard: 1.2.1 Berkeley DB 4.6.21.


    I've set up and installed everything necessary, including the BerkeleyDB. However, when I start squid, I get the following errors before it dies:

    (squidGuard): error while loading shared libraries: libdb-4.6.so: failed to map segment from shared object: Permission denied
    (squidGuard): error while loading shared libraries: libdb-4.6.so: failed to map segment from shared object: Permission denied
    (squidGuard): error while loading shared libraries: libdb-4.6.so: failed to map segment from shared object: Permission denied


    2008/02/21 10:57:22| WARNING: url_rewriter #19 (FD 24) exited
    2008/02/21 10:57:22| WARNING: url_rewriter #18 (FD 23) exited
    2008/02/21 10:57:22| WARNING: url_rewriter #17 (FD 22) exited
    2008/02/21 10:57:22| Too few url_rewriter processes are running
    FATAL: The url_rewriter helpers are crashing too rapidly, need help!

    To me, it looks like a permissions issue with the BerkeleyDB. I've got the exact configuration as the my old server, but the new versions include the DB. I've gone over and over the install instructions on the squidguard site, but can't seem to find anything.

    Here's the url_rewrite line from my squid.conf:
    url_rewrite_program /usr/local/bin/squidGuard -c /usr/local/squidGuard/squidGuard.conf

    And here is my entire squidguard.conf file:
    #
    # CONFIG FILE FOR SQUIDGUARD
    #
    # See *OMMITING DUE TO SQUIDGUARD URL* for more examples
    #

    dbhome /usr/local/squidGuard/db
    logdir /usr/local/squidGuard/log

    dest gambling{
    log gambling
    domainlist gambling/domains
    urllist gambling/urls
    }

    dest porn{
    log porn
    domainlist porn/domains
    urllist porn/urls
    }

    dest local-ok{
    domainlist local-ok/domains
    urllist local-ok/urls
    }

    dest local-block{
    log local-block
    domainlist local-block/domains
    urllist local-block/urls
    }


    acl {
    default {
    pass local-ok !local-block !gambling !porn all

    redirect LINE OMITTED DUE TO URL
    }
    }

  2. #2
    Just Joined!
    Join Date
    Dec 2005
    Posts
    4

    Not a Berkeley DB issue

    A co-worker of mine found the solution. I had selinux enabled. Once it was disabled and the box was rebooted, ta-da! I'm not sure how he discovered it or if it was just an educated guess, but it's working!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •