Find the answer to your Linux question:
Results 1 to 2 of 2
I have two computers, samson(win 2k server) and frodo(linux). i can connect to win2k server from linux through the command line like this. >smbclient //samson/download -U Administrator password then i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    5

    error: samba configuration


    I have two computers, samson(win 2k server) and frodo(linux).

    i can connect to win2k server from linux through the command line like this.

    >smbclient //samson/download -U Administrator password

    then i can just see the files from public directories existing in win 2k server from linux.

    and even though i ping win 2k server with the local ip and computer name on linux, i get a reply from it. but when i try to ping frodo on windows 2k server, i don't get the reply. but i get the reply by pinging the local ip of the linux machine.

    what i want to do is browse frodo in windows 2k server so that i can shares files and also use the server, too.

    on "Computers Near Me" on win 2k server, it shows "frodo", but when i try to browse, i get "Frodo is not accessible. The network path was not found.". i don't know why i can't get access to the linux machine from windows even though i can get access to windows from linux.

    here is my smb.conf
    [global]
    log file = /var/log/samba/%m.log
    load printers = yes
    smb passwd file = /etc/samba/smbpasswd
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*success fully*
    obey pam restrictions = yes
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    username map = /etc/samba/smbusers
    hosts allow = 192.168.1.101 192.168.1.100
    encrypt passwords = yes
    wins proxy = yes
    passwd program = /usr/bin/passwd %u
    dns proxy = no
    netbios name = frodo
    browseable = yes
    netbios aliases = frodo
    server string = samba server
    printing = cups
    default = public
    path = /tmp/download
    unix password sync = Yes
    workgroup = workgroup
    os level = 20
    auto services = public
    printcap name = /etc/printcap
    security = user
    max log size = 0
    pam password change = yes

    [homes]
    comment = Home Directories
    browseable = yes
    writeable = yes
    valid users = %S
    create mode = 0664
    directory mode = 0775


    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no


    [public]
    path = /home
    public = yes
    only guest = yes
    writable = yes
    printable = no
    browseable = yes

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Posts
    6
    I guess there is no wins server configured on the network or a master browser. Although Frodo shows in network the IP address is not known to the win2k machine.

    Try accessing Frodo using its IP address. In Windows Explorer type
    \\IP-of-Frodo\sharename

    and that should give you a response. You might want to add Frodo to your windoze lmhosts file. Im not sure where it is located coz I'm not very familiar with windows administration.

    See if that helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •