Find the answer to your Linux question:
Results 1 to 5 of 5
Hotmail rejects the emails I am sending using sendmail. They don't even become spam emails. They just never get there. Gmail gets them, and yahoo mail gets them as spam. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    15

    Hotmail rejecting my sendmail configuration


    Hotmail rejects the emails I am sending using sendmail. They don't even become spam emails. They just never get there. Gmail gets them, and yahoo mail gets them as spam.

    There must be something wrong with the sendmail.mc file.

    If you know more about it than I do, please check it out (assuming you're masochistic enough to enjoy looking at a sendmail.mc file )

    divert(-1)dnl
    dnl #
    dnl # This is the sendmail macro config file for m4. If you make changes to
    dnl # /etc/mail/sendmail.mc, you will need to regenerate the
    dnl # /etc/mail/sendmail.cf file by confirming that the sendmail-cf package is
    dnl # installed and then performing a
    dnl #
    dnl # make -C /etc/mail
    dnl #
    include(`/usr/share/sendmail-cf/m4/cf.m4')dnl
    VERSIONID(`setup for linux')dnl
    OSTYPE(`linux')dnl
    dnl #
    dnl # default logging level is 9, you might want to set it higher to
    dnl # debug the configuration
    dnl #
    dnl define(`confLOG_LEVEL', `9')dnl
    dnl #
    dnl # Uncomment and edit the following line if your outgoing mail needs to
    dnl # be sent out through an external mail server:
    dnl #
    dnl define(`SMART_HOST',`smtp.your.provider')dnl
    dnl #
    define(`confDEF_USER_ID',``8:12'')dnl
    dnl define(`confAUTO_REBUILD')dnl
    define(`confTO_CONNECT', `1m')dnl
    define(`confTRY_NULL_MX_LIST',true)dnl
    define(`confDONT_PROBE_INTERFACES',true)dnl
    define(`PROCMAIL_MAILER_PATH',`/usr/bin/procmail')dnl
    define(`ALIAS_FILE', `/etc/aliases')dnl
    define(`STATUS_FILE', `/var/log/mail/statistics')dnl
    define(`UUCP_MAILER_MAX', `2000000')dnl
    define(`confUSERDB_SPEC', `/etc/mail/userdb.db')dnl
    define(`confPRIVACY_FLAGS', `authwarnings,novrfy,noexpn,restrictqrun')dnl
    define(`confAUTH_OPTIONS', `A')dnl
    define(`POP_B4_SMTP_TAG')dnl
    HACK(`popauth')dnl
    dnl #
    dnl # The following allows relaying if the user authenticates, and disallows
    dnl # plaintext authentication (PLAIN/LOGIN) on non-TLS links
    dnl #
    dnl define(`confAUTH_OPTIONS', `A p')dnl
    dnl #
    dnl # PLAIN is the preferred plaintext authentication method and used by
    dnl # Mozilla Mail and Evolution, though Outlook Express and other MUAs do
    dnl # use LOGIN. Other mechanisms should be used if the connection is not
    dnl # guaranteed secure.
    dnl # Please remember that saslauthd needs to be running for AUTH.
    dnl #
    TRUST_AUTH_MECH(`EXTERNAL DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
    define(`confAUTH_MECHANISMS', `EXTERNAL GSSAPI DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
    dnl #
    dnl # Rudimentary information on creating certificates for sendmail TLS:
    dnl # cd /usr/share/ssl/certs; make sendmail.pem
    dnl # Complete usage:
    dnl # make -C /usr/share/ssl/certs usage
    dnl #
    dnl define(`confCACERT_PATH',`/etc/pki/tls/certs')dnl
    dnl define(`confCACERT',`/etc/pki/tls/certs/ca-bundle.crt')dnl
    dnl define(`confSERVER_CERT',`/etc/pki/tls/certs/sendmail.pem')dnl
    dnl define(`confSERVER_KEY',`/etc/pki/tls/certs/sendmail.pem')dnl
    dnl #
    dnl # This allows sendmail to use a keyfile that is shared with OpenLDAP's
    dnl # slapd, which requires the file to be readble by group ldap
    dnl #
    dnl define(`confDONT_BLAME_SENDMAIL',`groupreadablekey file')dnl
    dnl #
    dnl define(`confTO_QUEUEWARN', `4h')dnl
    dnl define(`confTO_QUEUERETURN', `5d')dnl
    dnl define(`confQUEUE_LA', `12')dnl
    dnl define(`confREFUSE_LA', `18')dnl
    define(`confTO_IDENT', `0')dnl
    dnl FEATURE(delay_checks)dnl
    FEATURE(`no_default_msa',`dnl')dnl
    FEATURE(`smrsh',`/usr/sbin/smrsh')dnl
    FEATURE(`mailertable',`hash -o /etc/mail/mailertable.db')dnl
    FEATURE(`virtusertable',`hash -o /etc/mail/virtusertable.db')dnl
    FEATURE(redirect)dnl
    FEATURE(always_add_domain)dnl
    FEATURE(use_cw_file)dnl
    FEATURE(use_ct_file)dnl
    dnl #
    dnl # The following limits the number of processes sendmail can fork to accept
    dnl # incoming messages or process its message queues to 12.) sendmail refuses
    dnl # to accept connections once it has reached its quota of child processes.
    dnl #
    dnl define(`confMAX_DAEMON_CHILDREN', 12)dnl
    dnl #
    dnl # Limits the number of new connections per second. This caps the overhead
    dnl # incurred due to forking new sendmail processes. May be useful against
    dnl # DoS attacks or barrages of spam. (As mentioned below, a per-IP address
    dnl # limit would be useful but is not available as an option at this writing.)
    dnl #
    dnl define(`confCONNECTION_RATE_THROTTLE', 3)dnl
    dnl #
    dnl # The -t option will retry delivery if e.g. the user runs over his quota.
    dnl #
    FEATURE(local_procmail,`',`procmail -t -Y -a $h -d $u')dnl
    FEATURE(`access_db',`hash -T<TMPF> -o /etc/mail/access.db')dnl
    FEATURE(`blacklist_recipients')dnl
    dnl # I don't know what this does yet: EXPOSED_USER(`rpcarnell')dnl
    dnl #
    dnl # For using Cyrus-IMAPd as POP3/IMAP server through LMTP delivery uncomment
    dnl # the following 2 definitions and activate below in the MAILER section the
    dnl # cyrusv2 mailer.
    dnl #
    dnl define(`confLOCAL_MAILER', `cyrusv2')dnl
    dnl define(`CYRUSV2_MAILER_ARGS', `FILE /var/lib/imap/socket/lmtp')dnl
    dnl #
    dnl # The following causes sendmail to only listen on the IPv4 loopback address
    dnl # 127.0.0.1 and not on any other network devices. Remove the loopback
    dnl # address restriction to accept email from the internet or intranet.
    dnl #
    DAEMON_OPTIONS(`Port=smtp, Name=MSA, M=E')dnl
    dnl #
    dnl # The following causes sendmail to additionally listen to port 587 for
    dnl # mail from MUAs that authenticate. Roaming users who can't reach their
    dnl # preferred sendmail daemon due to port 25 being blocked or redirected find
    dnl # this useful.
    dnl #
    dnl DAEMON_OPTIONS(`Port=submission, Name=MSA, M=Ea')dnl
    dnl #
    dnl # The following causes sendmail to additionally listen to port 465, but
    dnl # starting immediately in TLS mode upon connecting. Port 25 or 587 followed
    dnl # by STARTTLS is preferred, but roaming clients using Outlook Express can't
    dnl # do STARTTLS on ports other than 25. Mozilla Mail can ONLY use STARTTLS
    dnl # and doesn't support the deprecated smtps; Evolution <1.1.1 uses smtps
    dnl # when SSL is enabled-- STARTTLS support is available in version 1.1.1.
    dnl #
    dnl # For this to work your OpenSSL certificates must be configured.
    dnl #
    dnl DAEMON_OPTIONS(`Port=smtps, Name=TLSMTA, M=s')dnl
    dnl #
    dnl # The following causes sendmail to additionally listen on the IPv6 loopback
    dnl # device. Remove the loopback address restriction listen to the network.
    dnl #
    dnl DAEMON_OPTIONS(`port=smtp,Addr=::1, Name=MTA-v6, Family=inet6')dnl
    dnl #
    dnl # enable both ipv6 and ipv4 in sendmail:
    dnl #
    dnl DAEMON_OPTIONS(`Name=MTA-v4, Family=inet, Name=MTA-v6, Family=inet6')
    dnl #
    dnl # We strongly recommend not accepting unresolvable domains if you want to
    dnl # protect yourself from spam. However, the laptop and users on computers
    dnl # that do not have 24x7 DNS do need this.
    dnl #
    dnl ### I added the dnl <--- FEATURE(`accept_unresolvable_domains')dnl
    dnl #
    dnl FEATURE(`relay_based_on_MX')dnl
    dnl ---> this doesn't work with this sendmai-- > FEATURE('use_client_ptr')dnl
    dnl #
    dnl # Also accept email sent to "localhost.localdomain" as local email.
    dnl #
    LOCAL_DOMAIN('domain_Im_using.com')dnl
    dnl # the line below is something I removed *************
    dnl #LOCAL_DOMAIN(`localhost.localdomain')dnl
    dnl #
    dnl # The following example makes mail from this host and any additional
    dnl # specified domains appear to be sent from mydomain.com
    dnl #
    dnl ---> no need for this yet--> MASQUERADE_AS(`domain_Im_using.com')dnl
    dnl #
    dnl # masquerade not just the headers, but the envelope as well
    dnl #
    dnl FEATURE(masquerade_envelope)dnl
    dnl #
    dnl # masquerade not just @mydomainalias.com, but @*.mydomainalias.com as well
    dnl #
    dnl FEATURE(masquerade_entire_domain)dnl
    dnl #
    dnl MASQUERADE_DOMAIN(localhost)dnl
    dnl MASQUERADE_DOMAIN(localhost.localdomain)dnl
    dnl MASQUERADE_DOMAIN(mydomainalias.com)dnl
    MASQUERADE_DOMAIN(domain_Im_using.com)dnl
    MAILER(smtp)dnl
    MAILER(procmail)dnl
    MAILER(local)dnl


  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    I didn't look at your config, but if you are on that server (either ssh or local), do a telnet session to yahoo and hotmail and try to send a legitimate email telnet email - Google Search

    see if either give any errors. you might also sign up for an @aol.com account and try to send there. aol tends to give pretty good postmaster errors.

    when I had this problem (using postfix) it was because the ip address that I was sending email from didn't have an approprate ptr record. which is usually the case for spammers so it gets tagged/treated as spam.
    Ip Tools, DNS tools, internet tools, WHOIS, traceroute, ping, domain name tools

    go there and try to look up your info

    as much as I like to bag on aol, they do a good job of providing postmaster help
    Postmaster.Info : Troubleshooting E-mail Delivery
    (even though you didn't report aol troubles )

    oh, and check your logs, they may give some insight

  3. #3
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    You can't send email to hotmail without signing up to some special thing microsoft has where you give them a bunch of personal and server details...

    However, you can get around it by relaying you mail through a server that hotmail does accept mail from (your ISP's mail server should do the trick).
    Add this to the end of your sendmail.mc:
    Code:
    define(`SMART_HOST',`your.isps.mail.server')
    change 'your.isps.mail.server' to the name of the server you'll be relaying through.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    Quote Originally Posted by darkrose0510 View Post
    You can't send email to hotmail without signing up to some special thing microsoft has where you give them a bunch of personal and server details...
    not sure how true that is. my company has never done that with hotmail and we can send mail to them just fine. hotmail and a lot of others just require valid reverse records. not having a valid reverse record probably means you are on dhcp and not static and probably means you are a spammer.

  6. #5
    Just Joined!
    Join Date
    Mar 2008
    Posts
    69
    the big sites can be more demanding on authentication.

    I would look first in my bind/dns files or check with my host about my "PTR" records specially regarding my mail server...the ptr is like the reverse of what you normally do with website names.
    it looks up th ip and checks that the nservers are in sync with the website name..

    like a double look up

    you got them wrong and it is a good immediate flag

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •