Find the answer to your Linux question:
Results 1 to 9 of 9
I have a "dedicated server" that I've been using for miscellaneous uses. Lately I've noticed that both FTP and SSH access have been really slow to log me in. Once ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2007
    Posts
    18

    Slow Dedicated Server


    I have a "dedicated server" that I've been using for miscellaneous uses. Lately I've noticed that both FTP and SSH access have been really slow to log me in. Once I'm in, the SSH console is fast. I can vim ino a document and page through it in no time at all. On the other hand, sometimes I can't log into FTP at all (times out after I submit the password), and if I do get in, when I use a command-line FTP session, "ls" takes about 5 seconds of think time. The main web site hosted on it is really responsive, but another web site that is proxied through Apache on this box is sometimes really slow. bogomips measures performance score as 3333 which I assume is normal for an Athlon 2000+.

    I wonder if it's an overwhelmed hard drive. Just before this started hapeneing I did recently add a "feaure" to the web site that scans the directory structure of a given path and spits out an XML tree (yes, I was careful to filter out parent directory scans, etc). I added robots.txt to filter out the normal robots, but I wonder if it's getting pounded on by abusive robots. But the Apache logs don't indicate as much. In fact, there's very little use of this new feature I added according to the Apache logs.

    I've rebooted a few times, but there's been no change. And it seems to be getting worse.

    Before I call up the host provider and complain that it doesn't seem to be dedicated at all, has anyone seen this sort of behavior or have any ideas?

    Thanks,
    Jon

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    you can ssh and then run top or htop, whichever you have. then you could check that and log in using another window and see what happens. then you can do a tail l -f on some logs, like messages, and see if its reporting any errors when you try to logon.

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    18
    Thanks for the reply. I did try top, it shows nothing taking up more than a couple %.

    FTP accepts my password and then just hangs.

    I cannot understand this!!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    what ftp software are you using and have you tried different clients?

    can you update software, maybe see if there is an update for the ftp server.

    if you ssh in, then try to ftp to localhost and see if it hangs, that would rule out any internet or dns issues I would think.

  6. #5
    Just Joined!
    Join Date
    Jul 2007
    Posts
    18
    I was using FileZilla, Aptana, Dreamweaver, and command-line FTP client (Windows Vista). All were timing out after submitting my password with no feedback from the server.

    I tried updates, but the thing is this wasn't an issue until about a month or two ago, suddenly it started timing out.

    Oddly enough, I asked a friend to poke around at it. He timed out on FTP, logged in with SSH (quickly), updated his password, retried ftp, and connected. He told me it was working, so I tried. There was a long wait but I was able to get in with Aptana and command-line FTP (FileZilla was still timing out). Now, an hour or so later, I'm logging in fast.

    I noticed ProFTPd (which is what I'm using on the server, btw, which you asked about) is using PAM. Is this erratic behavior something anyone here has seen with PAM?? How can one predict or avoid this behavior??

    Thanks,
    Jon

  7. #6
    Just Joined!
    Join Date
    Mar 2008
    Posts
    69
    Quote Originally Posted by stimpy77 View Post
    Thanks for the reply. I did try top, it shows nothing taking up more than a couple %.

    FTP accepts my password and then just hangs.

    I cannot understand this!!
    when most things work fine, but when logging in via shell or ftp, ssh or not, it is usually a resolve issue with your nameservers/lookups when in hangs on password auth.
    when something happens and they are not resolving right it takes that good 10 second password check connection thing.

    that is the first place i would look..my dns records and files, ask the host about their issues too...do dig or nslookup a few times and see if something weird comes up

  8. #7
    Just Joined!
    Join Date
    Jul 2007
    Posts
    18
    Thanks, now we're getting somewhere. This is still erratically driving me nuts.

    I'll check out the dns/hosts issue. (That actually makes sense; I'm managing the box's BIND service directly on the box just because I can. I probably just need to update/replicate the host names to the hosts file for loopback.) Thanks!

  9. #8
    Just Joined!
    Join Date
    Jul 2007
    Posts
    18
    W00h00!! .. It worked! I made a few corrections to named (DNS), changed the hostname, changed /etc/hosts to use the loopback for the hostname being used, rebooted, and .. wee!! .. FTP login takes about 1 second.

  10. #9
    Just Joined!
    Join Date
    Mar 2008
    Posts
    69
    Quote Originally Posted by stimpy77 View Post
    W00h00!! .. It worked! I made a few corrections to named (DNS), changed the hostname, changed /etc/hosts to use the loopback for the hostname being used, rebooted, and .. wee!! .. FTP login takes about 1 second.
    now if you could just post your exact methods so half the web host comapnies can learn how to fix their servers for their clients...lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •