Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I ran nessus scan on my server and realised that my Openssh Protocol Version 1 was enabled. This can be a problem as this protocol is not completely cryptographically ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    jks
    jks is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    6

    openssh protocol option


    Hi,
    I ran nessus scan on my server and realised that my Openssh Protocol Version 1 was enabled. This can be a problem as this protocol is not completely cryptographically safe,so the software suggested me to set the 'Protocol' option to '2'. I am not sure how to do that as the first time i installed openssh , i used default paramemters. Can anybody help me with this problem?

  2. #2
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    there should be an ssh.conf or openssh.conf somewhere (probably in etc) try to find it, it will probably have the value PROTICOL, or you can do this
    Code:
    echo PROTOCOL="2" > /etc/openssh.conf
    just find the config, openssh's manuals and docs should be able to guide you through most of this.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  3. #3
    jks
    jks is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    6

    RE: openssh option

    Hi,

    Thanks for your response. There is a file sshd.config in /etc/ssh , I tried changing the line which said #protocol 2,1 to #protocol 2 and then restarted the ssh using /etc/rc.d/init.d/sshd restart command. Then I tried checking the protocol version using ssh -V but it shows the same output as before. Can you please tell me how can I check if my protocol version has actually changed. Also the code that you mentioned in your posted reply, I tried using that too but it didnt work. Can you help me with this.

    Thanks.

  4. $spacer_open
    $spacer_close
  5. #4
    jks
    jks is offline
    Just Joined!
    Join Date
    Aug 2004
    Posts
    6

    re:openssh

    Hi qub333,

    Thanks a lot the following code worked:
    Code:
    echo PROTOCOL="2" > /etc/ssh/sshd_config
    After restarting the sshd, I checked it by using telnet command (telnet://remotehost 22), it gave me the correct protocol version:
    SSH-2.0-OpenSSH_3.5P1

    Thanks
    J

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •