Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 26
Try to telnet to your pc. if it says connected you'll have a problem with one of your pc's. root@firewall ~# telnet 192.168.x.x 22 Trying 192.168.x.x... Connected to 192.168.x.x. Escape ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193

    Try to telnet to your pc. if it says connected you'll have a problem with one of your pc's.

    root@firewall ~# telnet 192.168.x.x 22
    Trying 192.168.x.x...
    Connected to 192.168.x.x.
    Escape character is '^]'.
    SSH-2.0-OpenSSH_3.8p1
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  2. #12
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    ok thanks..i 'll try it ..
    Linux For Ever!

  3. #13
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    i tried telnet from pc1 to pc2 and i get :
    linux:~ # telnet 192.168.0.2 22
    Trying 192.168.0.2...
    Connected to 192.168.0.2.
    Escape character is '^]'.
    SSH-1.99-OpenSSH_3.8.1p1

    Protocol mismatch.
    Connection closed by foreign host.
    when i try it from pc2 to pc1 i get:
    telnet:connect to address 192.168.0.1:connection refused
    what should be wrong?
    Linux For Ever!

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    you connect maybe from ssh2 to a ssh1. or from ssh1 to ssh2.

    Try this maybe it helps:

    ssh 192.168.x.x 22

    or this:

    ssh 192.168.x.x -1 or ssh 192.168.x.x -2

    -1 stands Force protocol version 1
    -2 stands Force protocol version 2

    Another question maybe stupid to ask, did you start ssh on both on the machines with example:

    /etc/init.d/sshd start

    Redhat / Fedora / Trustix

    service sshd start

    If the server is not running you can't login.
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  6. #15
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    maybe you're right..i'll try it.the daemons sshd are running for both pc's..
    Linux For Ever!

  7. #16
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    Allright I've got another think for you:

    Goto

    /root/.ssh/

    there you'll find the known_hosts

    open it with your favorite editor like pico, nano or vim.

    Look if your ip is allready there, if yes, delete the hole line with your ip address.

    Example of a line:

    192.168.0.100 ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAIEAvafJ73I5gnM6sjRNHVJsCt cnJk0F3zBhFSbOyxQI/ivbAX3etJNspAijYOaSUYLGLcV7AL9H2QRn86DR53a24IATnk5 f5BU4sL4VbHGbkPshAMwHABRX9RId0BggVgj+J2r7yHEsGjP7E Osf/Vixrux3OcYYp7DunYmR03xrojU=

    You'll need to delete this hole line.

    Save the file. Then reconnect to your other pc.

    Hopefully this will help you out.
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  8. #17
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    i figured out that sshd daemon is not running on my pc.i tried /etc/init.d/sshd start and it says failed..and ps -elf|grep sshd does not show anything.
    i installed openssh and configured with yast2 but nothing happens..
    i also tried what mystic_slayer said and i got this :
    linux:~ # ssh 192.168.0.1
    warning: Need basic cursor movement capability, using vt100
    warning: Authentication failed.
    Disconnected; connection lost (Connection closed by remote host.).
    what else to do?
    Linux For Ever!

  9. #18
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    Can you post a copy of your sshd_config file??? I will have a look at it and see if I can help you.

    vt100 error is OK, don't worry about this. The main one is the Authentication Failure.

    Armage

  10. #19
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    Code:
    #	$OpenBSD: sshd_config,v 1.68 2003/12/29 16:39:50 millert Exp $
    
    # This is the sshd server system-wide configuration file.  See
    # sshd_config(5) for more information.
    
    # This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin
    
    # The strategy used for options in the default sshd_config shipped with
    # OpenSSH is to specify options with their default value where
    # possible, but leave them commented.  Uncommented options change a
    # default value.
    
    #Port 22
    #Protocol 2,1
    #ListenAddress 0.0.0.0
    #ListenAddress ::
    
    # HostKey for protocol version 1
    #HostKey /etc/ssh/ssh_host_key
    # HostKeys for protocol version 2
    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key
    
    # Lifetime and size of ephemeral version 1 server key
    #KeyRegenerationInterval 1h
    #ServerKeyBits 768
    
    # Logging
    #obsoletes QuietMode and FascistLogging
    #SyslogFacility AUTH
    #LogLevel INFO
    
    # Authentication:
    
    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes
    
    #RSAAuthentication yes
    #PubkeyAuthentication yes
    #AuthorizedKeysFile	.ssh/authorized_keys
    
    # For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
    #RhostsRSAAuthentication no
    # similar for protocol version 2
    #HostbasedAuthentication no
    # Change to yes if you don't trust ~/.ssh/known_hosts for
    # RhostsRSAAuthentication and HostbasedAuthentication
    #IgnoreUserKnownHosts no
    # Don't read the user's ~/.rhosts and ~/.shosts files
    #IgnoreRhosts yes
    
    # To disable tunneled clear text passwords, change to no here!
    PasswordAuthentication no
    #PermitEmptyPasswords no
    
    # Change to no to disable s/key passwords
    #ChallengeResponseAuthentication yes
    
    # Kerberos options
    #KerberosAuthentication no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    #KerberosGetAFSToken no
    
    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes
    
    # Set this to 'yes' to enable support for the deprecated 'gssapi' authentication
    # mechanism to OpenSSH 3.8p1. The newer 'gssapi-with-mic' mechanism is included
    # in this release. The use of 'gssapi' is deprecated due to the presence of 
    # potential man-in-the-middle attacks, which 'gssapi-with-mic' is not susceptible to.
    #GSSAPIEnableMITMAttack no
    
    # Set this to 'yes' to enable PAM authentication (via challenge-response)
    # and session processing. Depending on your PAM configuration, this may
    # bypass the setting of 'PasswordAuthentication' and 'PermitEmptyPasswords'
    UsePAM yes 
    
    #AllowTcpForwarding yes
    #GatewayPorts no
    X11Forwarding yes 
    #X11DisplayOffset 10
    #X11UseLocalhost yes
    #PrintMotd yes
    #PrintLastLog yes
    #TCPKeepAlive yes
    #UseLogin no
    #UsePrivilegeSeparation yes
    #PermitUserEnvironment no
    #Compression yes
    #ClientAliveInterval 0
    #ClientAliveCountMax 3
    #UseDNS yes
    #PidFile /var/run/sshd.pid
    #MaxStartups 10
    
    # no default banner path
    #Banner /some/path
    
    # override default of no subsystems
    Subsystem	sftp	/usr/lib/ssh/sftp-server
    that's what it looks like..
    Linux For Ever!

  11. #20
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    Uncomment the following lines and give it a try:

    #HostKey /etc/ssh/ssh_host_rsa_key
    #HostKey /etc/ssh/ssh_host_dsa_key
    #HostbasedAuthentication no
    #RhostsRSAAuthentication no
    #IgnoreRhosts yes
    #IgnoreUserKnownHosts no
    #PermitEmptyPasswords no

    Uncomment and Change the following lines from:

    #LoginGraceTime 2m
    #PermitRootLogin yes
    #StrictModes yes

    to:

    LoginGraceTime 120
    PermitRootLogin no
    StrictModes yes

    Change this line PasswordAuthentication no to yes

    Let me know how you get on.

    Armage

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •