Find the answer to your Linux question:
Results 1 to 2 of 2
i have two computers. one has windows and the other computer(whose name is "Frodo") has redhat 9. i am trying to make one directory from linux accessible to windows by ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Posts
    5

    username and password prompt: samba configuration


    i have two computers. one has windows and the other computer(whose name is "Frodo") has redhat 9.

    i am trying to make one directory from linux accessible to windows by using samba.

    the problem is that i can see computer name in WorkGroup in windows. but when i try to browse, i get this prompt

    incorrect password or unknown username for:
    \\Frodo
    Connect As:
    Password:

    I have different username and password for windows and linux.
    so i tried windows's and linux's Administrator's password. none of them worked.

    i can't figure it out. here is my smb.conf

    [global]
    log file = /var/log/samba/%m.log
    smb passwd file = /etc/samba/smbpasswd
    load printers = yes
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*success fully*
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    obey pam restrictions = yes
    username map = /etc/samba/smbusers
    encrypt passwords = yes
    hosts allow = 192.168.1.101 192.168.1.100
    passwd program = /usr/bin/passwd %u
    wins proxy = yes
    dns proxy = no
    netbios name = frodo
    browseable = yes
    netbios aliases = frodo
    server string = samba server
    printing = cups
    default = public
    path = /tmp/download
    unix password sync = Yes
    workgroup = WORKGROUP
    os level = 20
    valid users = adm Administrator admin
    printcap name = /etc/printcap
    security = user
    max log size = 0
    pam password change = yes

    [homes]
    comment = Home Directories
    browseable = yes
    writeable = yes
    valid users = %S
    create mode = 0664
    directory mode = 0775



    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no
    # Set public = yes to allow user 'guest account' to print
    printable = yes

    [public]
    printable = no
    writeable = yes
    public = yes
    guest only = yes
    path = /home



    thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    UK
    Posts
    77
    In RH9 go to menu->system settings->server setting ->samba server
    Your share should be in the opening screen in configured correctly in the smb.conf file.

    Go to the preferences menu and select Samba Users. Click Add User.

    Select the appropriate Unix Username your Username maybe.
    Type in the Windows username you use.
    Then think of a samba password, this can be whatever you like.

    Now go back to Samba Server Configuration Screen. Highlight your shared path and click properties. Click the access tab. Your samba user you just created should be in the box. Click the check box. Click OK.

    Code:
    /etc/init.d/smb restart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •