Find the answer to your Linux question:
Results 1 to 5 of 5
Spam Assassin is flagging mail with a low spam score with the x-spam-flag:yes even when the score is set not to unless the score is over 5. I have checked ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5

    Spam Assassin Flagging Good E-mails


    Spam Assassin is flagging mail with a low spam score with the x-spam-flag:yes even when the score is set not to unless the score is over 5. I have checked everything and all seems to be in order. This only started a couple of days ago, and nothing was done to cause it. Thanks for any help, I have googled everything with no luck.

    Copied from Mime:
    X-NSCC-MailScanner-Information: Scanned
    X-NSCC-MailScanner: Found to be clean
    X-NSCC-MailScanner-SpamCheck: Spam, ORDB-RBL, SpamAssassin (score=0,
    required 3, autolearn=disabled)
    X-MailScanner-SpamScore: s
    X-NSCC-MailScanner-From: crongls@batch1.util.phx.redhat.com
    X-Spam-Flag: YES

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Posts
    2
    I started having this same issue last week. I have my spam threshold set to 7 and 9, yet emails with a score like .125 are still flagged as [SPAM?]. This strikes me as quite odd, since spamassassin has been working fine for years now. Suddenly, all emails, even ones with low scores are flagged as spam. Any help on this issue is appreciated.

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    2
    I believe I fixed this one. The problem is with MailScanner. It turns out MailScanner checks with several external databases to determine if a message is spam regardless of spamassasin's score. Last week or so one of those databases went down causing MailScanner to assume all mail is spam.

    To fix it, I just commented out the line "ORDB-RBL relays.ordb.org." in '/etc/MailScanner/spam.lists.conf' I would make sure to comment any line refering to that server if you have multiple lines in the config. Make sure to restart MailScanner.

    Hope that helps.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    Thanks, I will try it and see what happens and then post back.

  6. #5
    Just Joined!
    Join Date
    Jan 2008
    Posts
    5
    That worked, you are the man.

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •