Find the answer to your Linux question:
Results 1 to 3 of 3
Hello, I am having issues with getting the other systems in my house to connect and fileshare with my linux box. I have downloaded samba and ran it in server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    2

    [SOLVED] Samba, SWAT, nothing sees to work (Mandriva distro)


    Hello,

    I am having issues with getting the other systems in my house to connect and fileshare with my linux box.

    I have downloaded samba and ran it in server mode. I have set up the netbios name and the workgroup name. I had some issues with the netbios name as i had to edit some files to change the hostname from localhost to my computer name.

    I can't seem to get my windows boxes to see my linux box on the network even at the IP level. I tried to ping my server but nothing. It however can ping itself and get out on the network just fine.

    I configured LISA to set up trusted networks and such and even shut off shorewall thinking that there was some configuration that came out of the box that was screwing me up.

    Any other ideas?

    Thanks a bunch!

    Shawn

  2. #2
    Linux Newbie
    Join Date
    Feb 2008
    Location
    Bangalore, India
    Posts
    112
    Hello Shawn,
    Your network is nothing to do with your Samba. Did you try networking without samba. You just have to install samba-server package and start the smb service. After starting please check if you can see the 136,137,138 ports open on your box.

    Please provide more details like which os you are trying to install ? check if you see somthing nasty in /var/log/samba/error.log file.

    If you wann chat ping me on nilesh_patil82@ yahoo id.

    $ nilesh
    bigunix.blogspot.com
    Registered Linux User: #476440

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    2
    Nilesh,

    Thanks for the response. I feel as if I've been drug through a knot hole but I think I have it licked.

    Here is what I did:

    Couldn't seem to get SWAT to work. Tried everything. The I noticed that xinetd wasn't running. Started that up and SWAT worked fine.

    Couldn't ping my Linux box until I opened everything up via Personal Firewall service in the Configuration menu. I could then ping but that was it. I then narrowed it down to a few protocols and made sure SMB was among them.

    The clincher was, and I hesitate to say this as it is a bit embarassing, turning on "Client for MS Windows" on my test bed laptop. What prompted me to do that was my wife's computer was able to see the workgroup with no problems but my throw down laptop could not.

    Lastly I had to create an account on the laptop that matched my Linux account before I could write files to my Linux box.

    quite the learning experience but, laugh if you will, quite the sense of accomplishment.

    Thank you for your interest in my problem and your willingness to help!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •