Find the answer to your Linux question:
Results 1 to 2 of 2
Before I go too in-depth, my problem is that when I'm going through the mod_proxy instance, the FIN packets get sent from a *different* source port than the rest of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Banned
    Join Date
    Dec 2002
    Location
    Texas
    Posts
    242

    FIN packets with mod_proxy (Apache)


    Before I go too in-depth, my problem is that when I'm going through
    the mod_proxy instance, the FIN packets get sent from a *different*
    source port than the rest of the TCP transaction. Thus both hosts
    gets confused, packets are dropped so I can't complete a transaction.

    # httpd -v
    Server version: Apache/2.2.3
    Server built: Jan 15 2008 20:33:30

    Here's my mod_proxy config...

    <VirtualHost *>
    ServerName smoseman
    ProxyRequests Off
    <Proxy *>
    Order deny,allow
    Allow from all
    </Proxy>
    ProxyPass / http://remotehost:8000/path/
    ProxyPassReverse / http://remotehost:8000/path/
    <Location />
    Order allow,deny
    Allow from all
    </Location>
    RewriteEngine On
    RewriteCond %{REQUEST_URI} ^/path/(.*)
    RewriteRule ^/path/(.*) /$1 [R]
    </VirtualHost>

    An example of the problem: When I attempt to login to the website,
    the entire transaction is done through the source port 3965. When it
    comes time for the FIN ACK to close the connection, it's going out on
    source port 4476. remotehost asks for a RST, but since its on a
    different port its rejected. And I'm unable to login to the website.
    (Just viewing the website in read-only mode works fine.)

    When I attempt the same thing from the server directly using Firefox
    and going to the remotehost URL direct, the entire TCP connection uses
    a single source port (including the FIN ACK session).

    Why would going through mod_proxy result in the FIN ACK changing
    ports? Is this a bug? Am I missing a config option somewhere?

  2. #2
    Banned
    Join Date
    Dec 2002
    Location
    Texas
    Posts
    242
    Code:
    RewriteEngine On
    RewriteCond %{REQUEST_URI} ^/path/(.*)
    RewriteRule ^/path/(.*) /$1 [R]
    My problem appears to be related to mod_rewrite, not mod_proxy.
    The above will give me an error and fail a FORM based login screen.
    It will work using [P], but it carries over the /path/ in the URL, which
    is what we're trying to hide.

    That's all that farther I have come, so far. I need to see if there's
    a mod_rewrite option that I'm missing somewhere along the line...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •