Find the answer to your Linux question:
Results 1 to 6 of 6
I'm attempting to set up a home network file-server on my Debian PC/Server to simply serve up a bunch of folders for backing up, etc. but can't seem to get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    2

    Connecting to Samba from Windows


    I'm attempting to set up a home network file-server on my Debian PC/Server to simply serve up a bunch of folders for backing up, etc. but can't seem to get my windows machines to talk to the server.

    A rough situation of how everything fits together on the network:

    Router (provides switch, DHCP, internet, etc.)
    Server (Debian Etch with Samba version 3.0.24 installed)
    Windows XP PC: homepc
    Windows XP Laptop: laptop
    (hey, simple naming works best, no? )

    I need the two windows machines to be able to connect to a bunch of samba shares on Server. So far I have tried using the generic setup that was installed with Debian, simply adding shared folders through the Desktop > Administration > Shared Folder; and also by adding entries directly to the /etc/samba/smb.conf file.

    I've also added an extra user ('adduser -a matt' ... password ... 'smbpasswd -a matt' ... password ... 'smbpasswd -e matt') as many tutorials tell people to.

    Coming to try then to access the server, I get a user/password dialogue window on my windows machines. No matter what I put in here (the new user, a pre-existing user on the server or the windows machines) it always flashes straight back up at me, asking for the user/password again.

    Having looked at SWAT, I tried changing the security option to 'SHARE' (not having the option to use DOMAIN, ADS or SERVER on my network as far as I can tell). This then allows me to at least see what shares are available on the server, but on trying to access any of them I get the user/password prompt with a greyed out user box (set as SERVER\guest) and using no password, or using any of the passwords for any of the users on the server seems to do anything other than before (login window just comes straight back up).

    Attempting to connect locally using smbclient I get the following:

    Code:
    SERVER:/# smbclient -L SERVER
    Password:
    session setup failed: NT_STATUS_LOGON_FAILURE
    I haven't found solutions to any of the above (using google) that actually work, so I hoped someone might be able to help me fix this.

    In case it's any use, here's the 'testparm /etc/samba/smb.conf' readout:

    Code:
    SERVER:/# testparm /etc/samba/smb.conf
    Load smb config files from /etc/samba/smb.conf
    Processing section "[homes]"
    Processing section "[printers]"
    Processing section "[print$]"
    Processing section "[AnimeStoreA]"
    Processing section "[DVDISOs]"
    Processing section "[ComputerStuff]"
    Processing section "[Backups]"
    Loaded services file OK.
    WARNING: You have some share names that are longer than 12 characters.
    These may not be accessible to some older clients.
    (Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
    Server role: ROLE_STANDALONE
    Press enter to see a dump of your service definitions
    
    [global]
            workgroup = WORKGROUP
            server string = %h server
            obey pam restrictions = Yes
            passdb backend = tdbsam
            passwd program = /usr/bin/passwd %u
            passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
            syslog = 0
            log file = /var/log/samba/log.%m
            max log size = 1000
            dns proxy = No
            ldap ssl = no
            panic action = /usr/share/samba/panic-action %d
            invalid users = root
            include = /etc/samba/dhcp.conf
    
    [homes]
            comment = Home Directories
            valid users = %S
            create mask = 0700
            directory mask = 0700
            browseable = No
    
    [printers]
            comment = All Printers
            path = /var/spool/samba
            create mask = 0700
            printable = Yes
            browseable = No
    
    [print$]
            comment = Printer Drivers
            path = /var/lib/samba/printers
    
    [AnimeStoreA]
            path = /mnt/md0/Anime Store A
            read only = No
    
    [DVDISOs]
            path = /mnt/md1/DVDs
            read only = No
    
    [ComputerStuff]
            path = /mnt/md2/Computer Stuff
            read only = No
    
    [Backups]
            path = /mnt/md2/Backups
            read only = No
    Well, hopefully someone will reply to this . I'm going to go off and have lunch for a bit now.

  2. #2
    Just Joined!
    Join Date
    May 2008
    Posts
    42
    #Try this

    [Backups]

    path = /mnt/md2/Backups
    browseable = yes
    writeable = yes
    valid users = matt

    #always restart the samba service after saving the smb.conf file
    #/etc/init.d/samba restart

  3. #3
    Just Joined!
    Join Date
    May 2008
    Posts
    2
    Tried the above by nidhinmd and it made no difference to my situation.

    Still looking. Thanks anyway!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2008
    Posts
    19
    If you're not worried too much about security try adding this line to your shares:

    Code:
    guest ok = yes

  6. #5
    Just Joined! PsychoJock's Avatar
    Join Date
    May 2008
    Location
    Ashford, kent
    Posts
    23

    Talking

    Hiya Gone_Fishing,
    I had a wee spot of bother with Samba on Fedora 8 and found this:-

    Samba Fileserver With SWAT On Fedora 8 | HowtoForge - Linux Howtos and Tutorials

    I know it is for Fedora but the SWAT setup and the directories should work for most versions of Linux.

    Hope it helps!!

  7. #6
    Content Team
    Join Date
    Jul 2008
    Posts
    4
    Gone_Fishing, I am having similar issues, actually almost the exact same issue except for the fact that my server is acting as a DC with samba and its running Ubuntu 8.
    My setup acts just like yours did, did you happen to get it to work? If so could you post the fix so anyone else having samba problems will benefit?

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •