Find the answer to your Linux question:
Results 1 to 3 of 3
I'm trying to complie Apache with mod_authnz_ldap, here is what I'm running to compile: Code: ./configure --prefix=/etc/httpd \ --enable-actions \ --enable-alias \ --enable-asis \ --enable-auth_digest \ --enable-autoindex \ --enable-dav \ ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2008
    Location
    127.0.0.1
    Posts
    7

    Apache compile error


    I'm trying to complie Apache with mod_authnz_ldap, here is what I'm running to compile:

    Code:
    ./configure --prefix=/etc/httpd \
    --enable-actions \
    --enable-alias \
    --enable-asis \
    --enable-auth_digest \
    --enable-autoindex \
    --enable-dav \
    --enable-dav_fs \
    --enable-dir \
    --enable-env \
    --enable-expires \
    --enable-headers \
    --enable-info \
    --enable-log_config \
    --enable-rewrite \
    --enable-status \
    --enable-suexec \
    --enable-unique_id \
    --enable-version \
    --enable-vhost_alias \
    --enable-so \
    --with-apr=/usr/local/apr-httpd/ --with-apr-util=/usr/local/apr-util-httpd/ \
    --enable-authnz-ldap
    Problem:

    mod_authnz_ldap.c:41:2: #error mod_authnz_ldap requires APR-util to have LDAP support built in. To fix add --with-ldap to ./configure.

    Have I missed something here? Do I need to configure apr/apr-util before I run configure for apache?

    Any advise?

  2. #2
    Just Joined!
    Join Date
    Jun 2008
    Location
    127.0.0.1
    Posts
    7
    PS. I'm doing this on RHEL4U4

  3. #3
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    it looks like you need to also build it with ldap support. here is a link similar to this
    Building LDAP Authentication into Apache2 | brent.kearneys.ca

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •