I have specified gpgcheck=1 in yum.conf and this is the error I receive during the update (it is an RH9 box)
warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 731002fa
Error: Could not find the GPG Key necessary to validate pkg /var/cache/yum/updates-released/packages/sysklogd-1.4.1-14.legacy.9.i386.rpm
Error: You may want to run yum clean or remove the file:
/var/cache/yum/updates-released/packages/sysklogd-1.4.1-14.legacy.9.i386.rpm
Error: You may also check that you have the correct GPG keys installed


I have issued on RH9 box 'rpm --import /usr/share/rhn/RPM-GPG-KEY' so the key should theoretically be imported.

Any ideas? Thank you.