Find the answer to your Linux question:
Results 1 to 5 of 5
Hello all, I have solaris 5.9 running, I can't for the life of me recall how to open a port, and make it so it will be open even after ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie AboveNBeyond's Avatar
    Join Date
    Mar 2007
    Posts
    120

    Solaris port question... please help asap!!!


    Hello all,
    I have solaris 5.9 running, I can't for the life of me recall how to open a port, and make it so it will be open even after a reboot?

  2. #2
    Linux Newbie AboveNBeyond's Avatar
    Join Date
    Mar 2007
    Posts
    120
    I am sure this can be done. Can this not be done?

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Check /etc/services and remove # sign before relevant port.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Linux Newbie AboveNBeyond's Avatar
    Join Date
    Mar 2007
    Posts
    120
    Can the entry look like this...
    telelogic 36678/tcp # Telelogic Doors

    Or would the "telelogic" have to be exact to the service calling it?
    Or is there a way to just open it as listening generically such as...
    "listen 36678/tcp #Doors" ?

    Thanks.

  5. #5
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,746
    Just as in Linux, you have 2 options - either the process runs as a daemon (all the time) and grabs/opens the port, or you have inetd listening for connections and starting the corresponding process when something connects.

    So either start the daemon, or edit your inetd.conf for the required service.

    Example clip for FTP service that inetd listens for:

    Code:
    # FTPD - FTP server daemon
    # ftp   stream  tcp6    nowait  root    /usr/sbin/in.ftpd       in.ftpd -a
    ftp     stream  tcp     nowait  root    /usr/local/sbin/in.proftpd in.proftpd
    The "service" is defined as ftp - ftp must be defined in your /etc/services file with a port. If I wanted ftp to run on 3409, I'd change the ftp line in /etc/services from 21 to 3409.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •