Find the answer to your Linux question:
Results 1 to 3 of 3
I've been working on setting up this local SVN server on an Ubuntu machine. It's a pilot to try to get our group to switch to SVN. My latest problem ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Location
    PNW
    Posts
    16

    SVN timestamp issue


    I've been working on setting up this local SVN server on an Ubuntu machine. It's a pilot to try to get our group to switch to SVN.

    My latest problem is that when I update (commit) a file from a client (windows machine using TortoiseSVN), the client keeps the modification time of the file and not the commit time.

    I really don't care which time is used, as long as they time in the windows computer and the one in the repository match.

    So far the only way I've found is to delete the file and repull it from the repository (there has GOT to be a better solution).


    But the real problem is that the time stamp stored on the repository appears to be GMT, not local time. So when I pull it back it's about 8 hours off (I'm at GMT - .

    How can I ensure subversion uses local time, not GMT?

  2. #2
    Linux Enthusiast
    Join Date
    Apr 2004
    Location
    UK
    Posts
    682
    The latest version of TortoiseSVN allows for client side hook scripts

    You could combine the "Set file dates to the “last commit time”" option to make the local repository match the server times, and use a client side script to update files after you check them in.

    I'm not so sure about the timezone problem, I'd guess it's because the timezone on the server is set to GMT.

    I don't have a setup I can play with here, so these are mostly educated guesses.

    Let us know how you get on,

    Chris...
    To be good, you must first be bad. "Newbie" is a rank, not a slight.

  3. #3
    Just Joined!
    Join Date
    May 2008
    Location
    PNW
    Posts
    16
    Just for completion, I'll post the solution.

    I found my solution here:
    Feisty/Windows System Time Inconstancies [Archive] - Ubuntu Forums


    Quote Originally Posted by kebes
    1. Set date to current time, if required (instead of "11:02" use the current time):
    $ sudo date -s 11:02
    2. Update the hardware clock with the newly updated time:
    $ sudo /sbin/hwclock --systohc --localtime
    3. Check that the change took effect:
    $ /sbin/hwclock --localtime
    Tue 08 May 2007 11:01:41 AM EDT -0.641764 seconds
    4. Load the hardware clock time back into the system:
    $ /sbin/hwclock --hctosys --localtime
    This procedure has fixed my local time on ubuntu computer without the "use UTC" checkbox (which was part of what was messing things up I think).

    I checked the subversion timestamp and it now comes back with local/correct time.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •