Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
This probably won't make a bit of difference, but if you re-start apache will it work? How about if you remove your original symlinks and then re-create them? Neither of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Sep 2007
    Location
    Lafayette, IN
    Posts
    83

    This probably won't make a bit of difference, but if you re-start apache will it work? How about if you remove your original symlinks and then re-create them? Neither of those should matter, I wouldn't think, but lets get the little stupid things out of the way.

  2. #12
    Just Joined!
    Join Date
    Jun 2008
    Posts
    11
    Quote Originally Posted by Ben Cotton View Post
    This probably won't make a bit of difference, but if you re-start apache will it work? How about if you remove your original symlinks and then re-create them? Neither of those should matter, I wouldn't think, but lets get the little stupid things out of the way.
    Thanks for still hangin in there

    wow, I actually found what was cookin! ..it wasn't a "little stupid thing", but one thing led to another, and I found my way. I'm not gonna slap my forehead, cause this was no easy cookie to get out of the oven!

    Here's whats up:

    The scenarios i described are identical, there is no doubt about that. I tried to plough through the httpd.conf _once_more_ for any hints of whats going on...nada. Then when I tailed the access.log while testing those "little stupid things", I also noticed the error.log and it hit me that I hadn't tailed it, so I did and found something weird:
    [..] File does not exist: /usr/share/images/p.gif

    What the hell!?! usr/share?? where did that come from? ..2 minutes later i found this:
    Code:
    <IfModule mod_alias.c>
        Alias /images/ /usr/share/images/
    
        <Directory /usr/share/images/
             Options MultiViews
             AllowOverride None
             Order allow,deny
             Allow from all
        </Directory>
    </IfModule>
    ..in httpd.conf

    and there we go. My default httpd.conf had an alias named "images" which kind of overrides the symlink i made...

    Case closed! Thank you for letting me help myself hehe

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •