Ok this is the first time i would be setting up a webserver. I have installed the following things:

Apache 2.0.50
MySQL 4.0.20

Using Slackware 10.0.

As far as i know i had no problems during installation of all the applications.
(BTW: I used the guides here to Install all of the above applications:
Apache: http://www.linuxfromscratch.org/blfs...eb.html#apache
MySQL: http://www.linuxfromscratch.org/blfs...ent/mysql.html
PHP: http://www.linuxfromscratch.org/blfs...ntent/php.html)
But when I go to test to see if Apache was configured right after configuring the httpd.conf file so I typed http://localhost into Konqueror but i get the...

An error occurred while loading http://localhost/:

Could not connect to host localhost
and from what I've read that means Apache isn't running. So I go into the command prompt as root and type in the command apachectl start but i get a syntax error...

root@teamstp:~# apachectl start
Syntax error on line 207 of /etc/apache/httpd.conf:
Cannot load /usr/libexec/apache/mod_define.so into server: /usr/libexec/apache/mod_define.so: undefined symbol: ap_null_cleanup
so I went back to the httpd.conf and disabled that mod by putting the # at the starting of the line but I run the command apachectl start again but it just goes to the next LoadModule and get a simmillar error...

root@teamstp:~# apachectl start
Syntax error on line 208 of /etc/apache/httpd.conf:
Can't locate API module structure `config_log_module' in file /usr/lib/apache/mod_log_config.so: /usr/lib/libapr-0.so.0: undefined symbol: config_log_module
I saw that some of them had libexec/apache/mod_[name] and other had lib/apache/mod_[name] so i changed all of them to lib and tryed running it like that and I get the error that there is no such file or directory so i change them all to libexec but i then get the syntax errors again.

If anyone knows how to fix it or if need to be doing something diffrent then please reply any help would be good.

Also if you need to see my httpd.conf file or any more info then tell me. I didn't put it on here because i didn't want to make it a long ass post.

- ChriSTP