Find the answer to your Linux question:
Results 1 to 4 of 4
Hey everyone, I just set up an apache server on fc9, but now I am testing it out and it seems to only work locally... i can't get the test ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3

    Apache only works locally


    Hey everyone, I just set up an apache server on fc9, but now I am testing it out and it seems to only work locally... i can't get the test page up from another host on the network, and it also doesn't answer telnet on port 80. Yes, im a noob, so I probably overlooked something obvious. Help please!

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Have you the iptables service running? I think this runs by default in FC9 so it's more than likely blocking Apache/Port 80. You can either add a rule for Apache or disable it altogether.

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    When I was setting up I turned off the firewall, and the guide I was following (howtoforge) said to run iptables -L to verify it was off, it says iptables -L should display
    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    but on mine, it displays

    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED 
    ACCEPT     icmp --  anywhere             anywhere            
    ACCEPT     all  --  anywhere             anywhere            
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:ssh 
    REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited 
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited 
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination
    Anyway, something tells me I didn't successfully disable the firewall or iptables or whichever it is. How do I disable it? Thanks

  4. #4
    Just Joined!
    Join Date
    Aug 2008
    Posts
    3
    umm ok... I ran system-config-firewall again, which brings up the gui. it showed that the firewall was disabled, but just for kicks i enabled the firewall and checked the box next to http, and then whaddya know? it works. even dumber, i turned it right back off, and it still works. weird!

    Well thanks for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •