I tried and failed setting up a postfix server.... Vanilla communication between a computer and my server works. When i try and access from a blackberry it just does not work... I think i have problems in my main.cf. I apologize ahead of time for the EPIC FAILURE that is my main.cf

ERROR LOG:
Sep 6 14:33:33 skunkworks postfix/smtpd[7142]: connect from unknown[32.143.64.45]
Sep 6 14:33:36 skunkworks postfix/smtpd[7142]: warning: unknown[32.143.64.45]: SASL PLAIN authentication failed:
Sep 6 14:33:36 skunkworks postfix/smtpd[7142]: lost connection after AUTH from unknown[32.143.64.45]
Sep 6 14:33:36 skunkworks postfix/smtpd[7142]: disconnect from unknown[32.143.64.45]
Sep 6 14:33:52 skunkworks postfix/smtpd[7142]: warning: 32.143.64.45: hostname mobile-032-143-064-045.mycingular.net verification failed: No address associated with hostname
MAIN.CF
Code:
banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# setup for local generated mails
append_dot_mydomain = yes
masquerade_domains  = getwebinspired.net
myorigin = getwebinspired.net

# general stuff
myhostname = skunkworks.getwebinspired.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = skunkworks.mydomain.net,
                skunkworks,
                localhost,
                localhost.localdomain,
				hosteddomain.com

relayhost =
mynetworks = 10.0.0.0/8, mobile-032-143-243-220.mycingular.net , mobile-032-143-080-218.mycingular.net, 75-150-138-145-Philadelphia.hfc.comcastbusiness.net
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all

banner = $myhostname ESMTP $mail_name (Debian/GNU)
# helo restrictions
smtpd_delay_reject = yes
smtpd_helo_required = yes
smtpd_helo_restrictions =
        permit_mynetworks,
        reject_invalid_hostname,
        permit

# sender restrictions
smtpd_sender_restrictions =
        permit_sasl_authenticated,
        permit_mynetworks,
        reject_non_fqdn_sender,
        reject_unknown_sender_domain,
        permit

# recipient restriction
smtpd_recipient_restrictions =
        reject_unauth_pipelining,
        permit_sasl_authenticated,
        permit_mynetworks,
        reject_non_fqdn_recipient,
        reject_unknown_recipient_domain,
        reject_unauth_destination

#enable SMTP auth for relaying
smtpd_sasl_auth_enable       = yes
broken_sasl_auth_clients     = yes
smtpd_sasl_type              = dovecot
smtpd_sasl_path              = private/auth

# deliver with dovecot
dovecot_destination_recipient_limit = 1
mailbox_transport = dovecot
local_recipient_maps =
email server ip 10.10.10.199
firewall ip 10.10.10.1