Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    BIND not starting!

    I'm having troubles with BIND9, it says: "rndc: connect failed: connection refused". I have tried a bunch of solutions, but none worked. I do not have /etc/named.conf, /etc/rndc.conf, or /var/named or any sub-directories.

    I followed this tutorial to install it.

    It has never worked for me. Any help would be thanked. And what is Named?

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Nottingham, England
    Could be a firewalling issue, you'll probably need to a firewall exception to allow localhost to connect to port 953!
    Linux user #126863 - see

  3. #3
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    The Keystone State
    Bind requires that the key you defined in bind config is the same as the one in rndc config. Check to see that they are the same.

    How are you loading the key in bind?
    Are you running bind in a chroot environment?


    The adventure of a life time.

    Linux User #296285
    Get Counted

  4. $spacer_open
  5. #4
    Nevermind, I guess I didn't have rndc or something. I removed BIND and installed from apt-get (not the source). It said it was going to install rndc also, so...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts