Find the answer to your Linux question:
Results 1 to 3 of 3
I have two computers running etch, and samba was working perfectly. For reasons unknown, Samba broke on one computer, and the shares were no longer accessible. What I discovered is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    1

    Samba shares only visible using IP address but not host name


    I have two computers running etch, and samba was working perfectly. For reasons unknown, Samba broke on one computer, and the shares were no longer accessible. What I discovered is that on the affected computer, the shares are only visible if I use the IP address and not the host name. So, it seems like problem with nmbd. I copied my samba.conf from the working computer, and it didn't help. When I try to browse shares with SMB4K, I noticed that the hostname is being associated with an incorrect IP address. I set my IP address on the affected computer to static to correspond with the IP address I saw SMB4K looking toward. That solved my drive share problem, but not my printer share problem. I am thinking that there has to be a config file somewhere that is corrupted that I need to adjust. Any thoughts?

    I checked hosts.conf, hosts, hosts.allow, and hosts.deny for problems and couldn't see any problems.

  2. #2
    Just Joined!
    Join Date
    Sep 2009
    Posts
    3
    I have the same problem. Did you find out what it was?

    Thanks.

  3. #3
    Just Joined! Tarthen's Avatar
    Join Date
    Sep 2009
    Location
    Australia
    Posts
    40
    I had this problem at work... turned out that Winbind wasn't on, and wasn't joining the workgroup.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •