Find the answer to your Linux question:
Results 1 to 2 of 2
Ubuntu 8.04 Exim 4 I have 10 frozen messages in the queue and I can't delete them. Both of these commands: sudo exim -bpr | grep frozen | awk '{print ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2008
    Posts
    84

    Exim can't delete queue


    Ubuntu 8.04
    Exim 4

    I have 10 frozen messages in the queue and I can't delete them. Both of these commands:

    sudo exim -bpr | grep frozen | awk '{print $3}' | xargs exim -Mrm

    sudo exim4 -bp | awk '/^ *[0-9]+[mhd]/{print "exim -Mrm " $3}' | sh

    return Permission Denied. Also I know that only the sender of the mail can delete it so I tried it without sudo, still denied.

    I got these commands from two different places, does it matter if I use exim or exim4?

  2. #2
    Just Joined!
    Join Date
    Jun 2008
    Posts
    84
    Problem solved, should have put sudo in the second call to exim.

    sudo exim4 -bp | awk '/^ *[0-9]+[mhd]/{print "sudo exim -Mrm " $3}' | sh

    sudo exim4 -bpr | fgrep '*** frozen ***' | awk '{print $3}' | sudo xargs exim -Mrm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •