Find the answer to your Linux question:
Results 1 to 1 of 1
Hello! I just setup a new server today, and I'm already locked out of mysql ( yes i'm a n00b ). It's Ubuntu. I installed the server this morning, came ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    9

    Exclamation mysql > locked out of my server!


    Hello!
    I just setup a new server today, and I'm already locked out of mysql ( yes i'm a n00b ).

    It's Ubuntu. I installed the server this morning, came back to my office, and I can't do anything in mysql.

    I login like:
    mysql -u root
    that gets me in.

    then i run:
    UPDATE mysql.user SET Password='mypass' WHERE User='root';

    and get this error:
    ERROR 1142 (42000): UPDATE command denied to user ''@'localhost' for table 'user'

    I've tried removing the server, then reinstalling, and still have the same issue. any ideas would be a big help!


    ------- UPDATE--------
    ok, i've just tried removing it again using:
    apt-get --purge remove mysql-server-5.0

    which went fine, however now I'm getting this error on reinstall:


    root@harp:/home/sites/# apt-get install mysql-server
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    mysql-server is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 31 not upgraded.
    2 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up mysql-server-5.0 (5.0.51a-3ubuntu5.1) ...
    * Stopping MySQL database server mysqld [ OK ]
    /var/lib/dpkg/info/mysql-server-5.0.postinst: line 143: /etc/mysql/conf.d/old_passwords.cnf: No such file or directory
    dpkg: error processing mysql-server-5.0 (--configure):
    subprocess post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of mysql-server:
    mysql-server depends on mysql-server-5.0; however:
    Package mysql-server-5.0 is not configured yet.
    dpkg: error processing mysql-server (--configure):
    dependency problems - leaving unconfigured
    Errors were encountered while processing:
    mysql-server-5.0
    mysql-server
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@harp:/home/sites/#

    any ideas?




    thanks in advance for your time!
    -Ken
    Last edited by angst; 10-16-2008 at 05:51 PM. Reason: status update

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •