Find the answer to your Linux question:
Results 1 to 3 of 3
i had to go back and re type in like sudo route add -net 0.0.0.0 netmask 0.0.0.0 myrouterip i had to do that in order to get it back on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    33

    i rebooted and all eth0 settings gone


    i had to go back and re type in like sudo route add -net 0.0.0.0 netmask 0.0.0.0 myrouterip

    i had to do that in order to get it back on the network.

    doesnt it remember the settings so i can reboot without doing that each time?

    thanks

  2. #2
    Just Joined!
    Join Date
    Oct 2008
    Posts
    21
    you can add permanent gateway by appending
    GATEWAY=routerip
    in
    /etc/sysconfig/network
    or /etc/sysconfig/network-scripts/ifcfg-eth(or interfacename)
    or by appending
    route add -net 0.0.0.0 netmask 0.0.0.0 myrouterip
    to /etc/rc.d/rc.local

  3. #3
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    what linux distribution are you using? the settings hexcode posted may or may not work depending on your distro as network settings are stored differently in different distros

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •