Find the answer to your Linux question:
Results 1 to 2 of 2
For some reason sendmail stopped delivering email today. I finally got it working again by rebooting the server but now there are over 1100 files in /var/spool/mqueue which sendmail won't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    5

    [SOLVED] sendmail won't deliver mail in /var/spool/mqueue


    For some reason sendmail stopped delivering email today. I finally got it working again by rebooting the server but now there are over 1100 files in /var/spool/mqueue which sendmail won't deliver. When I run "mailq" it says /var/spool/mqueue is empty. Also "sendmail -v -q" exits immediately. Sendmail is delivering all new mail but not what is in mqueue.

    Any ideas on how to get sendmail to deliver these messages or how to troubleshoot why it doesn't seem to see them?

    Mez

    update: running "sendmail -v -qL" causes sendmail to list all 557 messages but it still doesn't actually deliver them. Any ideas?

  2. #2
    Just Joined!
    Join Date
    Oct 2008
    Posts
    5

    Solved!

    OK, I talked to the sysadmin at my workplace today and he found the issue. First, the queue files started with "Q" instead of "q" which tells sendmail to not send them again. Second, permissions were wrong on all of the files (666 instead of 644). After I renamed thefiles and corrected the permissions sendmail started delivering them!!

    Mez

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •