Find the answer to your Linux question:
Results 1 to 7 of 7
Hi folks, Debian Etch Postfix can't send and receive mails. On running; # /etc/init.d/postfix check # tail /var/log/mail.log Code: Nov 10 10:00:56 xen05 amavis[3329]: No decoder for .arj tried: arj, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778

    Postfix can't send and receive mails


    Hi folks,


    Debian Etch


    Postfix can't send and receive mails.


    On running;
    # /etc/init.d/postfix check

    # tail /var/log/mail.log
    Code:
    Nov 10 10:00:56 xen05 amavis[3329]: No decoder for       .arj  tried: arj, unarj
    Nov 10 10:00:56 xen05 amavis[3329]: No decoder for       .arc  tried: nomarch, arc
    Nov 10 10:00:56 xen05 amavis[3329]: No decoder for       .zoo  tried: zoo
    Nov 10 10:00:56 xen05 amavis[3329]: No decoder for       .lha  tried: lha
    Nov 10 10:00:56 xen05 amavis[3329]: No decoder for       .doc  tried: ripole
    Nov 10 10:00:56 xen05 amavis[3329]: No decoder for       .cab  tried: cabextract
    Nov 10 10:00:56 xen05 amavis[3329]: No decoder for       .tnef
    Nov 10 10:00:56 xen05 amavis[3329]: Internal decoder for .tnef
    Nov 10 10:00:56 xen05 amavis[3329]: No decoder for       .exe  tried: rar, unrar; lha; arj, unarj
    Nov 10 10:00:56 xen05 amavis[3329]: (!!) TROUBLE in pre_loop_hook: db_home directory is not writable: /var/lib/amavis/db at /usr/sbin/amavisd-new line 6921.
    Please advise where shall I check and how to fix the problem. TIA


    Edit:


    It was amavis problem.


    Ran
    # adduser clamav amavis

    adding the user clamav to the group amavis


    then problem gone but another problem surfaces;


    # /etc/init.d/postfix check

    # tail /var/log/mail.log
    Code:
    Nov 10 12:56:15 xen05 postfix/smtpd[2973]: lost connection after RCPT from localhost.localdomain[127.0.0.1]
    Nov 10 12:56:15 xen05 postfix/smtpd[2973]: disconnect from localhost.localdomain[127.0.0.1]
    Nov 10 13:09:48 xen05 postfix/master[2752]: reload configuration /etc/postfix
    Nov 10 13:10:25 xen05 postfix/smtpd[3006]: connect from localhost.localdomain[127.0.0.1]
    Nov 10 13:11:11 xen05 postfix/smtpd[3006]: EDC4F7824C: client=localhost.localdomain[127.0.0.1]
    Nov 10 13:11:49 xen05 postfix/cleanup[3008]: EDC4F7824C: message-id=<20081110131111.EDC4F7824C@xen05.satimis.com>
    Nov 10 13:11:49 xen05 postfix/qmgr[3002]: EDC4F7824C: from=<satimis@satimis.com>, size=383, nrcpt=1 (queue active)
    Nov 10 13:11:49 xen05 postfix/smtp[3009]: connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024)
    Nov 10 13:11:49 xen05 postfix/smtp[3009]: EDC4F7824C: to=<satimis@yahoo.com>, relay=none, delay=56, delays=56/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
    Nov 10 13:11:52 xen05 postfix/smtpd[3006]: disconnect from localhost.localdomain[127.0.0.1]

    postfix still can't send/receive mails.


    "... connect to 127.0.0.1[127.0.0.1]: Connection refused (port 10024) .." Why port 10024 comes into play?



    B.R.
    satimis


    B.R.
    satimis

  2. #2
    Linux User
    Join Date
    May 2008
    Location
    NYC, moved from KS & MO
    Posts
    251
    10024 is the default port that amavisd-new listens on, you should have a line similar to this:
    content_filter = amavis:[127.0.0.1]:10024
    in the output of
    postconf -n

    check in your /etc/postfix/master.cf to see there is something similar to
    amavis unix - - n - 3 smtp
    (some options here ...)


    127.0.0.1:10025 inet n - n - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    (and a few other options ...)

    Lastly, check if amavisd-new is still running
    ps ax|grep amavis

    You might see something different to the darkred colored amavis in your main.cf and master.cf but they should match each other whatever they are.

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Quote Originally Posted by secondmouse View Post
    10024 is the default port that amavisd-new listens on, you should have a line similar to this:
    content_filter = amavis:[127.0.0.1]:10024
    in the output of
    postconf -n

    check in your /etc/postfix/master.cf to see there is something similar to
    amavis unix - - n - 3 smtp
    (some options here ...)


    127.0.0.1:10025 inet n - n - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    (and a few other options ...)

    Lastly, check if amavisd-new is still running
    ps ax|grep amavis

    You might see something different to the darkred colored amavis in your main.cf and master.cf but they should match each other whatever they are.
    Hi,


    Thanks for your advice.


    Tried them before without result. Some of the mentioned options have been commented out later.


    # grep content_filter /etc/postfix/main.cf
    Code:
    #content_filter = amavis:[127.0.0.1]:10024

    # cat /etc/postfix/master.cf
    Code:
    [snip]
    smtp      inet  n       -       n       -       -       smtpd
    #smtp      inet  n       -       -       -       -       smtpd
    #   -o cleanup_service_name=pre-cleanup
    
    [snip]
    
    127.0.0.1:10025 inet    n       -       -       -       -       smtpd
        -o content_filter=
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o strict_rfc821_envelopes=yes
        -o mynetworks=127.0.0.0/8
        -o smtpd_error_sleep_time=0
        -o smtpd_soft_error_limit=1001
        -o smtpd_hard_error_limit=1001

    # ps ax | grep amavis
    Code:
     2405 ?        Ss     0:00 amavisd (master)
     2412 ?        S      0:00 amavisd (virgin child)
     2413 ?        S      0:00 amavisd (virgin child)
     2886 pts/0    R+     0:00 grep amavis

    B.R.
    satimis

  4. #4
    Linux User
    Join Date
    May 2008
    Location
    NYC, moved from KS & MO
    Posts
    251
    What's the error message with content_filter commented out? Could you post the output of postconf -n?

    Regards

  5. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778
    Quote Originally Posted by secondmouse View Post
    What's the error message with content_filter commented out? Could you post the output of postconf -n?
    Hi,


    I suppose the problem coming on MySQL.


    Made following test;


    On MySQL

    mysql> show tables;
    Code:
    +------------------+
    | Tables_in_maildb |
    +------------------+
    | aliases          |
    | domains          |
    | users            |
    +------------------+
    3 rows in set (0.00 sec)

    changed;
    Code:
    mysql> SELECT * from domains;
    +------+-----------------------+-----------+---------+
    | pkid | domain                | transport | enabled |
    +------+-----------------------+-----------+---------+
    |    1 | localhost             | virtual:  |       1 |
    |    2 | localhost.localdomain | virtual:  |       1 |
    |    3 | satimis.com.tld       | virtual:  |       1 |
    +------+-----------------------+-----------+---------+
    3 rows in set (0.00 sec)
    to;
    Code:
    mysql> SELECT * from domains;
    +------+-----------------------+-----------+---------+
    | pkid | domain                | transport | enabled |
    +------+-----------------------+-----------+---------+
    |    1 | localhost             | virtual:  |       1 |
    |    2 | localhost.localdomain | virtual:  |       1 |
    |    3 | satimis.com           | virtual:  |       1 |
    +------+-----------------------+-----------+---------+
    3 rows in set (0.00 sec)

    and


    change;
    Code:
    mysql> SELECT * from aliases;
    +------+----------------------------+--------------------------+---------+
    | pkid | mail                       | destination              | enabled |
    +------+----------------------------+--------------------------+---------+
    |    1 | postmaster@localhost       | root@localhost           |       1 |
    |    2 | sysadmin@localhost         | root@localhost           |       1 |
    |    3 | webmaster@localhost        | root@localhost           |       1 |
    |    4 | abuse@localhost            | root@localhost           |       1 |
    |    5 | root@localhost             | root@localhost           |       1 |
    |    6 | @localhost                 | root@localhost           |       1 |
    |    7 | @localhost.localdomain     | @localhost               |       1 |
    |    8 | @satimis.com               | satimisowner@satimis.com |       1 |
    |    9 | postmaster@satimis.com.tld | postmaster@satimis.com   |       1 |
    |   10 | abuse@satimis.com.tld      | abuse@satimis.com        |       1 |
    |   11 | stephen@satimis.com        | soduer@satimis.com       |       1 |
    +------+----------------------------+--------------------------+---------+
    11 rows in set (0.00 sec)

    to;
    Code:
    mysql> SELECT * from aliases;
    +------+------------------------+--------------------------+---------+
    | pkid | mail                   | destination              | enabled |
    +------+------------------------+--------------------------+---------+
    |    1 | postmaster@localhost   | root@localhost           |       1 |
    |    2 | sysadmin@localhost     | root@localhost           |       1 |
    |    3 | webmaster@localhost    | root@localhost           |       1 |
    |    4 | abuse@localhost        | root@localhost           |       1 |
    |    5 | root@localhost         | root@localhost           |       1 |
    |    6 | @localhost             | root@localhost           |       1 |
    |    7 | @localhost.localdomain | @localhost               |       1 |
    |    8 | @satimis.com           | satimisowner@satimis.com |       1 |
    |    9 | postmaster@satimis.com | postmaster@satimis.com   |       1 |
    |   10 | abuse@satimis.com      | abuse@satimis.com        |       1 |
    |   11 | stephen@satimis.com    | soduer@satimis.com       |       1 |
    +------+------------------------+--------------------------+---------+
    11 rows in set (0.00 sec)

    Also uncomment the line "content_filter = ...."


    # postconf -n
    Code:
    alias_database = hash:/etc/postfix/aliases
    alias_maps = hash:/etc/postfix/aliases
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    content_filter = amavis:[127.0.0.1]:10024
    delay_warning_time = 4h
    disable_vrfy_command = yes
    inet_interfaces = all
    local_recipient_maps =
    masquerade_exceptions = root
    maximal_backoff_time = 8000s
    maximal_queue_lifetime = 7d
    minimal_backoff_time = 1000s
    mydestination =
    myhostname = xen05.satimis.com
    mynetworks = 192.168.0.0/24, 127.0.0.0/8 ##
    mynetworks_style = host
    relayhost =
    smtp_helo_timeout = 60s
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_client_restrictions = reject_rbl_client sbl.spamhaus.org, reject_rbl_client dnsbl.njabl.org
    smtpd_data_restrictions = reject_unauth_pipelining
    smtpd_delay_reject = yes
    smtpd_hard_error_limit = 12
    smtpd_helo_required = yes
    smtpd_helo_restrictions = permit_mynetworks, warn_if_reject reject_non_fqdn_hostname, reject_invalid_hostname, permit
    smtpd_recipient_limit = 16
    smtpd_recipient_restrictions = reject_unauth_pipelining, permit_mynetworks, reject_non_fqdn_recipient, reject_unknown_recipient_domain, reject_unauth_destination, check_policy_service inet:127.0.0.1:60000, permit
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_path = /etc/postfix/sasl:/usr/lib/sasl2
    smtpd_sasl_security_options = noanonymous
    smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_non_fqdn_sender, reject_unknown_sender_domain, reject_unauth_pipelining, permitsmtpd_soft_error_limit = 3
    smtpd_tls_cert_file = /etc/postfix/postfix.cert
    smtpd_tls_key_file = /etc/postfix/postfix.key
    smtpd_use_tls = yes
    unknown_local_recipient_reject_code = 450
    virtual_alias_maps = mysql:/etc/postfix/mysql_alias.cf
    virtual_gid_maps = mysql:/etc/postfix/mysql_gid.cf
    virtual_mailbox_base = /var/spool/mail/virtual
    virtual_mailbox_domains = mysql:/etc/postfix/mysql_domains.cf
    virtual_mailbox_maps = mysql:/etc/postfix/mysql_mailbox.cf
    virtual_uid_maps = mysql:/etc/postfix/mysql_uid.cf

    # postfix reload
    postfix/postfix-script: refreshing the Postfix mail system

    # postfix check

    # tail /var/log/mail.log
    Code:
    Nov 15 07:14:22 xen05 postfix/smtpd[3380]: disconnect from unknown[121.24.66.55]
    Nov 15 07:17:42 xen05 postfix/anvil[3381]: statistics: max connection rate 1/60s for (smtp:121.24.66.55) at Nov 15 07:14:19
    Nov 15 07:17:42 xen05 postfix/anvil[3381]: statistics: max connection count 1 for (smtp:121.24.66.55) at Nov 15 07:14:19
    Nov 15 07:17:42 xen05 postfix/anvil[3381]: statistics: max cache size 1 at Nov 15 07:14:19
    Nov 15 07:20:00 xen05 postfix/postfix-script: refreshing the Postfix mail system
    Nov 15 07:20:00 xen05 postfix/master[2775]: reload configuration /etc/postfix
    Nov 15 07:20:00 xen05 postfix/qmgr[3394]: B3F6E78304: from=<satimis@yahoo.com>, size=1431, nrcpt=1 (queue active)
    Nov 15 07:20:01 xen05 postfix/virtual[3396]: warning: mysql query failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'hosts=127.0.0.1='root@satimis.com' and enabled = 1' at line 1
    Nov 15 07:20:01 xen05 postfix/virtual[3396]: warning: table virtual_mailbox_maps: lookup root@satimis.com: Success
    Nov 15 07:20:01 xen05 postfix/virtual[3396]: B3F6E78304: to=<root@satimis.com>, relay=virtual, delay=7240, delays=7240/0.03/0/0.11, dsn=4.3.5, status=deferred (mail system configuration error)
    Error indicated.


    Sent a mail to satimis@satimis.com on Gmail.


    # tail /var/log/mail.log
    Code:
    Nov 15 07:23:25 xen05 postfix/smtpd[3471]: disconnect from localhost.localdomain[127.0.0.1]
    Nov 15 07:23:25 xen05 postfix/qmgr[3394]: 4258778309: from=<satimisliu@gmail.com>, size=2217, nrcpt=1 (queue active)
    Nov 15 07:23:25 xen05 amavis[2412]: (02412-01) FWD via SMTP: <satimisliu@gmail.com> -> <satimis@satimis.com>, 250 2.6.0 Ok, id=02412-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4258778309
    Nov 15 07:23:25 xen05 postfix/virtual[3472]: warning: mysql query failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'hosts=127.0.0.1='satimis@satimis.com' and enabled = 1' at line 1
    Nov 15 07:23:25 xen05 postfix/virtual[3472]: warning: table virtual_mailbox_maps: lookup satimis@satimis.com: Success
    Nov 15 07:23:25 xen05 amavis[2412]: (02412-01) Passed CLEAN, [209.85.198.247] [209.85.198.247] <satimisliu@gmail.com> -> <satimis@satimis.com>, Message-ID: <ca46cd50811142318v2126b94dqd99a0bdb92ffbae2@mail.gmail.com>, mail_id: F4+fUTBje8c5, Hits: -, queued_as: 4258778309, 892 ms
    Nov 15 07:23:25 xen05 amavis[2412]: (02412-01) TIMING [total 911 ms] - SMTP EHLO: 151 (17%)17, SMTP pre-MAIL: 1 (0%)17, mkdir tempdir: 4 (0%)17, create email.txt: 3 (0%)18, SMTP pre-DATA-flush: 8 (1%)18, SMTP DATA: 19 (2%)21, body_digest: 4 (0%)21, gen_mail_id: 2 (0%)21, mkdir parts: 0 (0%)21, mime_decode: 53 (6%)27, get-file-type1: 78 (9%)36, parts_decode: 0 (0%)36, update_cache: 8 (1%)37, decide_mail_destiny: 1 (0%)37, fwd-connect: 171 (19%)55, fwd-mail-from: 6 (1%)56, fwd-rcpt-to: 210 (23%)79, fwd-data-cmd: 1 (0%)79, write-header: 3 (0%)80, fwd-data-contents: 2 (0%)80, fwd-data-end: 40 (4%)84, fwd-rundown: 7 (1%)85, prepare-dsn: 4 (0%)85, main_log_entry: 115 (13%)98, update_snmp: 12 (1%)99, unlink-1-files: 5 (1%)100, rundown: 2 (0%)100
    Nov 15 07:23:25 xen05 postfix/smtp[3469]: 0288678306: to=<satimis@satimis.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=2, delays=0.96/0.01/0.29/0.76, dsn=2.6.0, status=sent (250 2.6.0 Ok, id=02412-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4258778309)
    Nov 15 07:23:25 xen05 postfix/qmgr[3394]: 0288678306: removed
    Nov 15 07:23:25 xen05 postfix/virtual[3472]: 4258778309: to=<satimis@satimis.com>, relay=virtual, delay=0.43, delays=0.26/0.03/0/0.14, dsn=4.3.5, status=deferred (mail system configuration error)

    Mail arrived saying "table virtual_mailbox_maps: lookup satimis@satimis.co m: Success ....". But can't find it nor rejected to Gmail. I think it is bouncing on Internet.


    # /home/satimis/postfinger
    Code:
    postfinger - postfix configuration on Sat Nov 15 07:49:09 UTC 2008
    version: 1.30
    
    --System Parameters--
    mail_version = 2.3.8
    hostname = xen05.satimis.com
    uname = Linux xen05.satimis.com 2.6.18-xen #1 SMP Fri May 18 16:11:33 BST 2007 i686 GNU/Linux
    
    --Packaging information--
    looks like this postfix comes from deb package: postfix-ii  postfix         2.3.8-2+etch1               A high-performance mail transport agent
    
    --main.cf non-default parameters--
    alias_database = hash:/etc/postfix/aliases
    alias_maps = hash:/etc/postfix/aliases
    broken_sasl_auth_clients = yes
    content_filter = amavis:[127.0.0.1]:10024
    delay_warning_time = 4h
    disable_vrfy_command = yes
    local_recipient_maps =
    masquerade_exceptions = root
    maximal_backoff_time = 8000s
    maximal_queue_lifetime = 7d
    mydestination =
    mynetworks = 192.168.0.0/24, 127.0.0.0/8 ##
    mynetworks_style = host
    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    smtpd_client_restrictions = reject_rbl_client sbl.spamhaus.org, reject_rbl_client dnsbl.njabl.org
    smtpd_data_restrictions = reject_unauth_pipelining
    smtpd_hard_error_limit = 12
    smtpd_helo_required = yes
    smtpd_helo_restrictions = permit_mynetworks, warn_if_reject reject_non_fqdn_hostname, reject_invalid_hostname, permit
    smtpd_recipient_limit = 16
    smtpd_recipient_restrictions = reject_unauth_pipelining, permit_mynetworks, reject_non_fqdn_recipient, reject_unknown_recipient_domain, reject_unauth_destination, check_policy_service inet:127.0.0.1:60000, permit
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_path = /etc/postfix/sasl:/usr/lib/sasl2
    smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_non_fqdn_sender, reject_unknown_sender_domain, reject_unauth_pipelining, permitsmtpd_soft_error_limit = 3
    smtpd_tls_cert_file = /etc/postfix/postfix.cert
    smtpd_tls_key_file = /etc/postfix/postfix.key
    smtpd_use_tls = yes
    smtp_helo_timeout = 60s
    unknown_local_recipient_reject_code = 450
    virtual_alias_maps = mysql:/etc/postfix/mysql_alias.cf
    virtual_gid_maps = mysql:/etc/postfix/mysql_gid.cf
    virtual_mailbox_base = /var/spool/mail/virtual
    virtual_mailbox_domains = mysql:/etc/postfix/mysql_domains.cf
    virtual_mailbox_maps = mysql:/etc/postfix/mysql_mailbox.cf
    virtual_uid_maps = mysql:/etc/postfix/mysql_uid.cf
    
    --master.cf--
    smtp      inet  n       -       n       -       -       smtpd
    smtps     inet  n       -       n       -       -       smtpd
        -o smtpd_tls_wrappermode=yes
        -o smtpd_sasl_auth_enable=yes
    587       inet  n       -       n       -       -       smtpd
        -o smtpd_enforce_tls=yes
        -o smtpd_sasl_auth_enable=yes
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    tlsmgr    unix  -       -       n       300     1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       -       -       -       smtp
    relay     unix  -       -       -       -       -       smtp
            -o fallback_relay=
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipientscalemail-backend unix  -       n       n       -       2       pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    amavis    unix  -       -       -       -       2       smtp
        -o smtp_data_done_timeout=1200
        -o smtp_send_xforward_command=yes
    127.0.0.1:10025 inet    n       -       -       -       -       smtpd
        -o content_filter=
        -o local_recipient_maps=
        -o relay_recipient_maps=
        -o smtpd_restriction_classes=
        -o smtpd_client_restrictions=
        -o smtpd_helo_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o strict_rfc821_envelopes=yes
        -o mynetworks=127.0.0.0/8
        -o smtpd_error_sleep_time=0
        -o smtpd_soft_error_limit=1001
        -o smtpd_hard_error_limit=1001
    pre-cleanup unix n      -       -       -       0       cleanup
        -o virtual_alias_maps=
        -o canonical_maps=
        -o sender_canonical_maps=
        -o recipient_canonical_maps=
        -o masquerade_domains=
    
    -- end of postfinger output --

    # mysql -h 127.0.0.1 -u satimis -pemmanuel
    Code:
    ERROR 1045 (28000): Access denied for user 'satimis'@'localhost' (using password : YES)
    satimis is not an user of MySQL.


    # mysql -h 127.0.0.1 -u root -pemmanuel
    Code:
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: Y ES)
    It is the same.


    # postconf -d | grep mail_version
    Code:
    mail_version = 2.3.8

    B.R.
    satimis

  6. #6
    Linux User
    Join Date
    May 2008
    Location
    NYC, moved from KS & MO
    Posts
    251
    What's the output of
    cat /etc/postfix/mysql_domains.cf
    and
    cat /etc/postfix/mysql_mailbox.cf

    Seems there's a problem in the database setup.

  7. #7
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,778

    Solved

    Quote Originally Posted by secondmouse View Post
    What's the output of
    cat /etc/postfix/mysql_domains.cf
    and
    cat /etc/postfix/mysql_mailbox.cf

    Seems there's a problem in the database setup.
    Yes. You're right. The problem is on /etc/postfix/mysql_mailbox.cf
    Code:
    .....
    where_field=id  hosts=127.0.0.1
    ...
    They were on the same line. Then I re-edited the file;
    Code:
    ...
    where_field=id  
    hosts=127.0.0.1
    ...
    breaking them into 2 lines.


    # /etc/init.d/mysql reload

    # /etc/init.d/postfix reload
    # /etc/init.d/postfix check

    making sure no mistake.

    Sent mails to satimis@satimis.com on Gmail. Mails arrived without problem.


    # ls /var/spool/mail/virtual/Stephen/
    Code:
    cur  new  tmp
    directories were created automatically on the arrival of the first mail.


    Now the mail server can send and receive mails. Thanks


    B.R.
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •