Find the answer to your Linux question:
Results 1 to 2 of 2
We are having strange problems with Squid and some secure web sites. Sometimes it just makes the site unbearably slow and other times it appears to just time out completely. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    2

    Squid problem with secure sites


    We are having strange problems with Squid and some secure web sites. Sometimes it just makes the site unbearably slow and other times it appears to just time out completely. We are using Squid3-3.0.STABLE9-6.1 on SuSE Linux Enterprise Server 10 SP1. I see messages in the access.log like this which look OK:

    04/Dec/2008:09:31:06 13509 <ip addr deleted> TCP_MISS/200 64653 CONNECT <host deleted>:443 <user deleted> DIRECT/<ip deleted> -

    The we're having problems with works great if we disable going through the proxy in IE but if we use the proxy the pages don't come up completely. The only way we can see a page is to hit the stop button and we get part of the page.

    This isn't happening for every secure site people use, just some of them. I also tried STABLE8 previously and it had similar problems. I also tried telling IE to bypass the proxy for that web site but that didn't seem to work either (stupid IE!).

    Any help would be appreciated.

  2. #2
    Just Joined!
    Join Date
    Dec 2008
    Posts
    2
    Well, the squid list had the answer to this one. The problem with with TCP Window Scaling. Because of broken routers or firewalls out there I had to turn it off. That fixed the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •