I'm running ubuntu 8.04 with vnc4server.

I'm trying to get my vnc server to listen on a specific interface. I don't want it listening on localhost, I want it listening on a virtual tun interface I setup, tun0, ip 10.6.7.0.

I tried adding the "-interface" option to the vnc4server script but Xvnc doesn't like it, "Unrecognized option: -interface".

How would I make vnc listen on a specific interface?