Find the answer to your Linux question:
Results 1 to 5 of 5
Im trying to set up database cache on my server centos 5 amd athlon 64 bit.. I am attempting to input similar settings to my previous server fedora 4.. Code: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    4

    Error setting up Mysql database cache


    Im trying to set up database cache on my server centos 5 amd athlon 64 bit.. I am attempting to input similar settings to my previous server fedora 4..

    Code:
    [mysqld]
    
    Query_cache_limit=2M
    Query_cache_size=25%
    Query_cache_type=1
    Thread_cache_size=128
    Key_buffer = 25%
    Join_buffer = 4M
    Table_cache=25%
    Sort_buffer=4M
    Read_rnd_buffer_size=1%
    Tmp_table_size=10% (or 32M, whichever is greater)
    
    set-variable=local-infile=0
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    user=mysql
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1
    
    [mysqld_safe]
    log-error=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    but when i go restart mysql i get the following error /usr/libexec/mysqld: unknown variable 'Query_cache_type=1'

    Is there something changed in between version/ or i've missed when changing to centos?

  2. #2
    Just Joined! cheapscotchron's Avatar
    Join Date
    Dec 2008
    Location
    swamps of jersey
    Posts
    68
    looks ok.
    not sure about the right case.
    did you try all lower case?
    e.g. query_cache_type=1

  3. #3
    Linux Newbie
    Join Date
    Apr 2008
    Location
    India
    Posts
    170
    Hi,

    Edit your my.cnf and set query_cache_type = 1

    "
    query_cache_type = 1

    "

    That will do the trick
    Regards
    David Anand
    -->Success is the list of failures ...!!!

  4. #4
    Just Joined!
    Join Date
    Jan 2009
    Location
    North Shields, UK
    Posts
    8

    Thumbs up

    Try setting all variables lower case, as already suggested.

    Tmp_table_size=10% (or 32M, whichever is greater)
    If you have been looking at a guide such as the one here, then remember that you need to change the %'s to actual values (about half way down on that page)

    Hope that helps

    Regards

    HelpQuick

  5. #5
    Just Joined!
    Join Date
    Oct 2007
    Posts
    4
    Thanks... changed the % to actual values ie (32M) and all settings worked fine..

    Brought the load average down a bit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •