Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all, i finally compiled mod_userdir.c successfully with apxs and rehashed the server. But then it shutdown. Which wasnt the intended action. So i checked /usr/local/apache2/logs/error_log and found this. Code: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52

    UserDIr help


    Hi all, i finally compiled mod_userdir.c successfully with apxs and rehashed the server. But then it shutdown. Which wasnt the intended action.

    So i checked /usr/local/apache2/logs/error_log and found this.


    Code:
    [Sat Jan 31 09:26:52 2009] [notice] SIGHUP received.  Attempting to restart
    lt-httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: module userdir_module is built-in and can't be loaded
    I've searched this via google but the only solutions i got were to reinstall apache. And im not looking to do that. So does anyone have a solution i can do to fix this?

  2. #2
    Just Joined!
    Join Date
    Dec 2007
    Location
    Bangalore
    Posts
    33
    check for the configuration on line 53 of /usr/local/apache2/conf/httpd.conf.

    Also run
    /usr/local/apache2/bin/apachectl configtest
    httpd -l | grep -i user

    The above might help you. Also post the results of above...

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Well i did what you said. First command i did was:

    Code:
    computer:/usr/local/apache2/bin# ./apachectl configtest
    httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: module userdir_module is built-in and can't be loaded
    Then i did the second command.

    Code:
    computer:/etc/httpd-2.2.11# ./httpd -l | grep -i user
      mod_authz_user.c
      mod_userdir.c
    I edited /usr/local/apache2/conf/httpd.conf and commented out line 53. And the web server launched fine. But i couldnt access my userdir. Would you like me to paste the contents of mod_userdir.conf ?


    EDIT:

    I ran that first command again while the web server is running and got this.

    Code:
    computer:/usr/local/apache2/bin# ./apachectl configtest
    Syntax OK
    But again its not allowing me to view my userdir =/ Help..

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    52
    Bump




    Anyone?

  6. #5
    Just Joined!
    Join Date
    Dec 2007
    Location
    Bangalore
    Posts
    33
    mod_userdir will be enabled by default
    afaik there is no need to compile it and Load the module.
    comment line 53 and start ur server and then try to access user dirs.

    check the syntax on line 53 and post it if possible.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •