Find the answer to your Linux question:
Results 1 to 3 of 3
I got problem about sshd service can not resolve. I build one usb boot linux myself. ( using linux RHEL5.2 kernel version 2.6.18-92.el5 and openssh-server-4.3p2-26.el5 from rhel dvd rpm package ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Feb 2009
    Posts
    101

    Angry can not login to ssh server


    I got problem about sshd service can not resolve.
    I build one usb boot linux myself.
    ( using linux RHEL5.2 kernel version 2.6.18-92.el5 and openssh-server-4.3p2-26.el5 from rhel dvd rpm package )
    my booting mothed:
    modify kernel booting llike this:

    title usbboot
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.25 ro root=/dev/sda1 init=/bin/bash
    initrd /boot/initrd-2.6.25.img <- rebuild by hand include usb code modules and usb module

    After booting into usb linux and get /bin/bash environment.

    rebuild some device by hand:

    mknod /dev/urandom c 1 9 &> /dev/null
    mknod /dev/random c 1 8 &> /dev/null
    mknod /dev/pts/1 c 136 1
    mknod /dev/pts/2 c 136 2
    mknod /dev/pts/3 c 136 3
    chown root:tty /dev/pts/*
    mkdir /dev/input
    mknod /dev/input/mice c 13 63
    mknod /dev/input/mouse0 c 13 32

    after that, I am make sure some directory would be writable.

    /bin/mount -t tmpfs tmpfs /tmp
    /bin/mount -t tmpfs tmpfs /var/log
    /bin/mount -t tmpfs tmpfs /var/lock
    /bin/mount -t tmpfs tmpfs /var/tmp
    /bin/mount -t tmpfs tmpfs /etc/ssh
    /bin/mount -t tmpfs tmpfs /etc/ppp
    /bin/mount -t tmpfs tmpfs /etc/sysconfig/network-scripts
    /bin/mount -t tmpfs tmpfs /var/empty/sshd/etc

    after insert network device module define ip address.
    I can use this command /etc/init.d/sshd start , sshd server works.
    there is somethng problem.

    problem 1: I can not ssh to another server. ( resolv by hand , but I thought it's not the best )
    I found the problem, /dev/tty is not one correct device

    echo 2 > /dev/tty
    bash: /dev/tty: No such device or address
    (I have try mknod /dev/tty c 5 0 , chown root:tty /dev/tty chmod 666 /dev/tty but doesnt work)

    echo 2 > /dev/tty1
    I found /dev/tty1 works. so I run this command

    rm -rf /dev/tty ; ln -s /dev/tty1 /dev/tty
    so I can ssh login to another Linux server.




    problem 2: after I run /etc/init.d/sshd/start. and use ssh client from antoher computer. after entype password. I can not get shell environment. what's the problem ?

    I use ssh -vvvv root@usbcomputer

    there is some debug information.


    [root@dns ~]# ssh 10.1.1.10 -vvvv
    OpenSSH_4.3p2, OpenSSL 0.9.8b 04 May 2006
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug2: ssh_connect: needpriv 0
    debug1: Connecting to 10.1.1.10 [10.1.1.10] port 22.
    debug1: Connection established.
    debug1: permanently_set_uid: 0/0
    debug1: identity file /root/.ssh/identity type -1
    debug1: identity file /root/.ssh/id_rsa type -1
    debug1: identity file /root/.ssh/id_dsa type -1
    debug1: loaded 3 keys
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3
    debug1: match: OpenSSH_4.3 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.3
    debug2: fd 3 setting O_NONBLOCK
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
    debug2: kex_parse_kexinit:
    debug2: kex_parse_kexinit:
    debug2: kex_parse_kexinit: first_kex_follows 0
    debug2: kex_parse_kexinit: reserved 0
    debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
    debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
    debug2: kex_parse_kexinit: none,zlib@openssh.com
    debug2: kex_parse_kexinit: none,zlib@openssh.com
    debug2: kex_parse_kexinit:
    debug2: kex_parse_kexinit:
    debug2: kex_parse_kexinit: first_kex_follows 0
    debug2: kex_parse_kexinit: reserved 0
    debug2: mac_init: found hmac-md5
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug2: mac_init: found hmac-md5
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug2: dh_gen_key: priv key bits set: 119/256
    debug2: bits set: 473/1024
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug3: check_host_in_hostfile: filename /root/.ssh/known_hosts
    debug3: check_host_in_hostfile: filename /etc/ssh/ssh_known_hosts
    debug3: check_host_in_hostfile: filename /root/.ssh/known_hosts
    debug3: check_host_in_hostfile: filename /etc/ssh/ssh_known_hosts
    debug2: no key of type 0 for host 10.1.1.10
    debug3: check_host_in_hostfile: filename /root/.ssh/known_hosts2
    debug3: check_host_in_hostfile: filename /etc/ssh/ssh_known_hosts2
    debug3: check_host_in_hostfile: filename /root/.ssh/known_hosts
    debug3: check_host_in_hostfile: filename /etc/ssh/ssh_known_hosts
    debug2: no key of type 2 for host 10.1.1.10
    The authenticity of host '10.1.1.10 (10.1.1.10)' can't be established.
    RSA key fingerprint is bb:e1:15:3a:35:34:ce:88:d9:81:52:b7:77:17:52:3e.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added '10.1.1.10' (RSA) to the list of known hosts.
    debug2: bits set: 517/1024
    debug1: ssh_rsa_verify: signature correct
    debug2: kex_derive_keys
    debug2: set_newkeys: mode 1
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug2: set_newkeys: mode 0
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug2: service_accept: ssh-userauth
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug2: key: /root/.ssh/identity ((nil))
    debug2: key: /root/.ssh/id_rsa ((nil))
    debug2: key: /root/.ssh/id_dsa ((nil))
    debug1: Authentications that can continue: publickey,gssapi-with-mic,password
    debug3: start over, passed a different list publickey,gssapi-with-mic,password
    debug3: preferred gssapi-with-mic,publickey,keyboard-interactive,password
    debug3: authmethod_lookup gssapi-with-mic
    debug3: remaining preferred: publickey,keyboard-interactive,password
    debug3: authmethod_is_enabled gssapi-with-mic
    debug1: Next authentication method: gssapi-with-mic
    debug3: Trying to reverse map address 10.1.1.10.
    debug1: Unspecified GSS failure. Minor code may provide more information
    No credentials cache found

    debug1: Unspecified GSS failure. Minor code may provide more information
    No credentials cache found

    debug1: Unspecified GSS failure. Minor code may provide more information
    No credentials cache found

    debug2: we did not send a packet, disable method
    debug3: authmethod_lookup publickey
    debug3: remaining preferred: keyboard-interactive,password
    debug3: authmethod_is_enabled publickey
    debug1: Next authentication method: publickey
    debug1: Trying private key: /root/.ssh/identity
    debug3: no such identity: /root/.ssh/identity
    debug1: Trying private key: /root/.ssh/id_rsa
    debug3: no such identity: /root/.ssh/id_rsa
    debug1: Trying private key: /root/.ssh/id_dsa
    debug3: no such identity: /root/.ssh/id_dsa
    debug2: we did not send a packet, disable method
    debug3: authmethod_lookup password
    debug3: remaining preferred: ,password
    debug3: authmethod_is_enabled password
    debug1: Next authentication method: password
    root@10.1.1.10's password:
    debug3: packet_send2: adding 64 (len 52 padlen 12 extra_pad 64)
    debug2: we sent a password packet, wait for reply
    debug1: Authentication succeeded (password).
    debug1: channel 0: new [client-session]
    debug3: ssh_session2_open: channel_new: 0
    debug2: channel 0: send open
    debug1: Entering interactive session.
    debug2: callback start
    debug2: client_session2_setup: id 0
    debug2: channel 0: request pty-req confirm 0
    debug3: tty_make_modes: ospeed 38400
    debug3: tty_make_modes: ispeed 38400
    debug3: tty_make_modes: 1 3
    debug3: tty_make_modes: 2 28
    debug3: tty_make_modes: 3 127
    debug3: tty_make_modes: 4 21
    debug3: tty_make_modes: 5 4
    debug3: tty_make_modes: 6 0
    debug3: tty_make_modes: 7 0
    debug3: tty_make_modes: 8 17
    debug3: tty_make_modes: 9 19
    debug3: tty_make_modes: 10 26
    debug3: tty_make_modes: 12 18
    debug3: tty_make_modes: 13 23
    debug3: tty_make_modes: 14 22
    debug3: tty_make_modes: 18 15
    debug3: tty_make_modes: 30 0
    debug3: tty_make_modes: 31 0
    debug3: tty_make_modes: 32 0
    debug3: tty_make_modes: 33 0
    debug3: tty_make_modes: 34 0
    debug3: tty_make_modes: 35 0
    debug3: tty_make_modes: 36 1
    debug3: tty_make_modes: 37 0
    debug3: tty_make_modes: 38 1
    debug3: tty_make_modes: 39 0
    debug3: tty_make_modes: 40 0
    debug3: tty_make_modes: 41 0
    debug3: tty_make_modes: 50 1
    debug3: tty_make_modes: 51 1
    debug3: tty_make_modes: 52 0
    debug3: tty_make_modes: 53 1
    debug3: tty_make_modes: 54 1
    debug3: tty_make_modes: 55 1
    debug3: tty_make_modes: 56 0
    debug3: tty_make_modes: 57 0
    debug3: tty_make_modes: 58 0
    debug3: tty_make_modes: 59 1
    debug3: tty_make_modes: 60 1
    debug3: tty_make_modes: 61 1
    debug3: tty_make_modes: 62 0
    debug3: tty_make_modes: 70 1
    debug3: tty_make_modes: 71 0
    debug3: tty_make_modes: 72 1
    debug3: tty_make_modes: 73 0
    debug3: tty_make_modes: 74 0
    debug3: tty_make_modes: 75 0
    debug3: tty_make_modes: 90 1
    debug3: tty_make_modes: 91 1
    debug3: tty_make_modes: 92 0
    debug3: tty_make_modes: 93 0
    debug1: Sending environment.
    debug3: Ignored env HOSTNAME
    debug3: Ignored env TERM
    debug3: Ignored env SHELL
    debug3: Ignored env HISTSIZE
    debug3: Ignored env KDE_NO_IPV6
    debug3: Ignored env SSH_CLIENT
    debug3: Ignored env QTDIR
    debug3: Ignored env QTINC
    debug3: Ignored env SSH_TTY
    debug3: Ignored env USER
    debug3: Ignored env LS_COLORS
    debug3: Ignored env KDEDIR
    debug3: Ignored env MAIL
    debug3: Ignored env PATH
    debug3: Ignored env INPUTRC
    debug3: Ignored env PWD
    debug1: Sending env LANG = zh_CN.UTF-8
    debug2: channel 0: request env confirm 0
    debug3: Ignored env KDE_IS_PRELINKED
    debug3: Ignored env SSH_ASKPASS
    debug3: Ignored env SHLVL
    debug3: Ignored env HOME
    debug3: Ignored env LOGNAME
    debug3: Ignored env QTLIB
    debug3: Ignored env CVS_RSH
    debug3: Ignored env SSH_CONNECTION
    debug3: Ignored env LESSOPEN
    debug3: Ignored env G_BROKEN_FILENAMES
    debug3: Ignored env _
    debug2: channel 0: request shell confirm 0
    debug2: fd 3 setting TCP_NODELAY
    debug2: callback done
    debug2: channel 0: open confirm rwindow 0 rmax 32768
    debug2: channel 0: rcvd adjust 131072

    <----- can not get sshd ( usb ) shell environment back.

    in usb disk --> pstree | grep ssh
    found "--sshd---sshd----bash--" and bash pid (435)

    ls /proc/435/fd -l

    lrwx------ 1 root root 64 Feb 11 10:22 0 --> socket:[469]
    lrwx------ 1 root root 64 Feb 11 10:22 1 --> socket:[469]
    lrwx------ 1 root root 64 Feb 11 10:22 2 --> socket:[471]


    netstat -nt [ usb disk ]
    tcp 0 0 10.1.1.10:22 10.1.1.11:3456 ESTABLISHED


    please help me to resolve this problem ..

    Thank you very much.

  2. #2
    Linux Newbie
    Join Date
    Apr 2008
    Location
    India
    Posts
    170
    check the permission of /var/log/btmp
    it must be 600 and check the iptable rules
    Regards
    David Anand
    -->Success is the list of failures ...!!!

  3. #3
    Linux Newbie
    Join Date
    Feb 2009
    Posts
    101
    it's nothing happy. I build linux by myown (use rpm and default kernel version )
    I found one thing.

    normally: ssh client ---> server ( server would fork one sshd process to respond client access, and there is one PID is /proc directory, in this folder, thereis one subdirectory named "fd" some link file in there. normally link to /dev/pts/1)

    but my ssh server with "fd" directory link to socket or pipe file, I want to konw how to resolv this problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •