Find the answer to your Linux question:
Results 1 to 3 of 3
Right where to start! I've been using vmware 1.07 on my Gentoo colo box and thought I'd go for vmware 2.0. All seems to have gone through fine without a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2009
    Posts
    2

    Gentoo - VMWare Server 2 - 503 Service Unavailable


    Right where to start!

    I've been using vmware 1.07 on my Gentoo colo box and thought I'd go for vmware 2.0. All seems to have gone through fine without a problem but when trying to access the interface http://<ip>:8222 or https://<ip>:8333 I get the 503 service unavailable error. So after some digging I so far have this info:

    The box is running:

    Apache2
    PHP
    Mysql
    Shoutcast
    SC_trans
    IRSSI

    uname
    Linux 2.6.27-gentoo-r7




    tail -12 /var/log/vmware/hostd.log

    2009-02-11 10:06:45.352 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.352 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.353 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.354 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.354 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.355 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.355 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.356 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.356 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.357 'Proxysvc Req00003' 3063372688 warning Connection to server localhost:8308 failed with error Connection refused. Retrying...
    2009-02-11 10:06:45.358 'Proxysvc Req00003' 3063372688 warning Exception while processing request: Connection refused


    netstat -plnt
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:8000 0.0.0.0:* LISTEN 5601/sc_serv
    tcp 0 0 0.0.0.0:8001 0.0.0.0:* LISTEN 5601/sc_serv
    tcp 0 0 0.0.0.0:8002 0.0.0.0:* LISTEN 5609/sc_serv
    tcp 0 0 0.0.0.0:8003 0.0.0.0:* LISTEN 5609/sc_serv
    tcp 0 0 0.0.0.0:8004 0.0.0.0:* LISTEN 5581/sc_serv
    tcp 0 0 0.0.0.0:8005 0.0.0.0:* LISTEN 5581/sc_serv
    tcp 0 0 0.0.0.0:902 0.0.0.0:* LISTEN 10336/vmware-authdl
    tcp 0 0 0.0.0.0:8006 0.0.0.0:* LISTEN 5594/sc_serv
    tcp 0 0 0.0.0.0:8007 0.0.0.0:* LISTEN 5594/sc_serv
    tcp 0 0 0.0.0.0:8008 0.0.0.0:* LISTEN 5587/sc_serv
    tcp 0 0 0.0.0.0:8009 0.0.0.0:* LISTEN 5587/sc_serv
    tcp 0 0 0.0.0.0:8010 0.0.0.0:* LISTEN 5615/sc_serv
    tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 5296/mysqld
    tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN 476/smbd
    tcp 0 0 0.0.0.0:8011 0.0.0.0:* LISTEN 5615/sc_serv
    tcp 0 0 0.0.0.0:8333 0.0.0.0:* LISTEN 10445/vmware-hostd
    tcp 0 0 127.0.0.1:8307 0.0.0.0:* LISTEN 10445/vmware-hostd
    tcp 0 0 0.0.0.0:21556 0.0.0.0:* LISTEN 621/sshd
    tcp 0 0 127.0.0.1:1080 0.0.0.0:* LISTEN 404/sockd
    tcp 0 0 0.0.0.0:7996 0.0.0.0:* LISTEN 5621/sc_serv
    tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN 476/smbd
    tcp 0 0 0.0.0.0:7997 0.0.0.0:* LISTEN 5621/sc_serv
    tcp 0 0 0.0.0.0:8222 0.0.0.0:* LISTEN 10445/vmware-hostd
    tcp 0 0 0.0.0.0:7998 0.0.0.0:* LISTEN 5627/sc_serv
    tcp 0 0 0.0.0.0:7999 0.0.0.0:* LISTEN 5627/sc_serv
    tcp6 0 0 :::80 :::* LISTEN 325/apache2
    tcp6 0 0 :::21556 :::* LISTEN 621/sshd


    /etc/init.d/vmware status
    Bridged networking on /dev/vmnet0 is running
    Host network detection is not running
    Host-only networking on /dev/vmnet1 is running
    DHCP server on /dev/vmnet1 is running
    Host-only networking on /dev/vmnet8 is running
    DHCP server on /dev/vmnet8 is running
    NAT networking on /dev/vmnet8 is running
    Module vmmon loaded
    Module vmnet loaded


    nano /etc/hosts

    127.0.0.1 mansell.fluidcanvas.co.uk mansell localhost


    revdep-rebuild
    * Generated new 3_broken.rr
    * Assigning files to packages
    * !!! /usr/bin/vmware-mount not owned by any package is broken !!!
    * /usr/bin/vmware-mount -> (none)
    * !!! /usr/lib/vmware/webAccess/java/jre1.5.0_15/lib/i386/awt_robot not owned by any package is broken !!!
    * /usr/lib/vmware/webAccess/java/jre1.5.0_15/lib/i386/awt_robot -> (none)
    * !!! /usr/lib/vmware/webAccess/java/jre1.5.0_15/lib/i386/libjsoundalsa.so not owned by any package is broken !!!
    * /usr/lib/vmware/webAccess/java/jre1.5.0_15/lib/i386/libjsoundalsa.so -> (none)
    * !!! /usr/lib/vmware/webAccess/java/jre1.5.0_15/lib/i386/motif21/libmawt.so not owned by any package is broken !!!
    * /usr/lib/vmware/webAccess/java/jre1.5.0_15/lib/i386/motif21/libmawt.so -> (none)
    * Generated new 4_raw.rr and 4_owners.rr
    * Found some broken files, but none of them were associated with known packages
    * Unable to proceed with automatic repairs.
    * The broken files are listed in 4_owners.rr

    Could the clue be in here?

    cheers

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    sounds like a screwed up install to me, did you uninstall vmware 1 first?

  3. #3
    Just Joined!
    Join Date
    Feb 2009
    Posts
    2
    Quote Originally Posted by coopstah13 View Post
    sounds like a screwed up install to me, did you uninstall vmware 1 first?
    yeah I did a emerge -C vmware-server and vmware-modules

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •