Find the answer to your Linux question:
Results 1 to 2 of 2
I'm trying to set up a samba server on my machine that will be accessible to everyone at my school. I've managed to get it so that people can connect ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246

    Setting up my netbios name in Samba


    I'm trying to set up a samba server on my machine that will be accessible to everyone at my school. I've managed to get it so that people can connect to my share by specifying my IP address, but not by my netbios name (thepenguin). How can I broadcast this name so that people can just type that?

    Here's the global section of my /etc/samba/smb.conf file:
    Code:
    [global]
       workgroup = WESLEYAN
       server string = Slackware Linux
       security = share
       hosts allow = 10. 127. 129.133.
       load printers = no
       log file = /var/log/samba.log
       max log size = 3000
       SO_RCVBUF=8192 SO_SNDBUF=8192
       socket options = TCP_NODELAY
       dns proxy = no
       netbios name = thepenguin
    Anybody see anything obviously wrong?

    EDIT: I just realized that I should have posted this in the Servers forum. Oops. You can move it if you'd like, Mods.
    Situations arise because of the weather,
    And no kinds of love are better than others.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    ***Moved to Servers***

    The obvious: did you restart samba after changing that setting in your config?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •