Find the answer to your Linux question:
Results 1 to 2 of 2
I have a tomcat application using Jasper reports which I have inherited the maintenance of. It use to run under Resin and I have converted to Apache/Tomcat. The last piece ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17

    Question [SOLVED] using OLD jasper reports with current software


    I have a tomcat application using Jasper reports which I have inherited the maintenance of. It use to run under Resin and I have converted to Apache/Tomcat. The last piece to get working uses Jasper reports. Last time this was working, we used jasperreports-1.3.0.jar but when I tried to use a report I get a JRException trying to load the xxx.jasper file - here is the "cause":

    cause: net.sf.jasperreports.engine.base.JRBaseReport; local class incompatible: stream classdesc serialVersionUID = 608, local class serialVersionUID = 10200

    So I read that upgrading jasper might fix the problem and brought the system up to j/jasperreports-3.1.4.jar (and other jars)/

    I still get the same error. I assume that the .jasper file(s - there are several for many reports) need to be re-done somehow.

    Can anyone give me a clue how I upgrade the .jasper files and/or .jrxml files? Is there some utility to bring them up to date?

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Posts
    17

    got it

    simply need to always recompile the .jrxml file - no saving time with .jasper files

    thanks for all the fish

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •