Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    North Carolina

    how about this
    NameVirtualHost *:80
    you reference the name in each of the other virtual host containers as *:80, I believe it should match the name based virtual host directive.

    I believe you would then change your <virtual host *> lines to <virtual host *:80> to match the namebased......

    oh wait, are you using apache 1.3 or 2.X?

    in 1.3 its NameVirtualhost, in 2.X its NameBasedVirtualHost

    name based virtual hosting - Google Search

    first link is for 1.3 and second is for 2.X

    if you posted the version already, my bad.

  2. #12
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Either at home or at work or down the pub

    Try something like this

    	ServerAdmin webmaster@localhost
    	ServerName xfc
    	DocumentRoot /home/elija/sites/xfc/public-html/
    	<Directory />
    		Options Indexes FollowSymLinks MultiViews
    		AllowOverride All
    		Order allow,deny
    		allow from all
    	ErrorLog /home/elija/sites/xfc/logs/error.log
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
    	CustomLog /home/elija/sites/xfc/logs/access.log combined
    	ServerSignature On
    This is one of the virtual hosts from my development machine. I am running several sites on that machine and the only difference between the files is the paths to the sites and the server name which is the url.

    Replace the IP Addresses with the IP Address of your server.

    Hope this helps.
    Should you be sitting wondering,
    Which Batman is the best,
    There's only one true answer my friend,
    It's Adam Bloody West!

    The Fifth Continent

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts