Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
configure: error: Unable to find required gettext library !!! ERROR: dev-php/php-4.3.8 failed. when emerging php, I've remerged gettext and the Locale-gettext no dice, any ideas? Ive already emerged apache correctly.......
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396

    php/php_mod install issues


    configure: error: Unable to find required gettext library

    !!! ERROR: dev-php/php-4.3.8 failed.


    when emerging php, I've remerged gettext and the Locale-gettext no dice, any ideas? Ive already emerged apache correctly....
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Is there any more information? I grepped bugs.gentoo.org and nothing turned up for that version of php.

    That's really not a definitive error message (gotta love those)...Does it specify the library file that it needs? Just really anything that could possibly give us some more info would be awesome.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    Sure, no worrries, its during the configure process

    checking for FreeType 1.x support... /usr
    checking for FreeType 2... /usr
    checking for T1lib support... /usr
    checking whether to enable truetype string function in GD... no
    checking whether to enable JIS-mapped Japanese font support in GD... no
    checking for GNU gettext support... yes
    checking for bindtextdomain in -lintl... no
    checking for bindtextdomain in -lc... no
    configure: error: Unable to find required gettext library

    !!! ERROR: dev-php/mod_php-4.3.8 failed.
    !!! Function econf, Line 362, Exitcode 1
    !!! econf failed


    unfortunetly thats all..... I've searched around for a bindtextdomain file, but to no avail.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Why not try and disable gettext IIRC its a use flage so something like
    Code:
    USE="-gettext" emerge php

  6. #5
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    Ok, I tried it with -truetext the only USE flag that was at all realted to this
    but still same error....I'll keep looking, but its really odd that i would be so stumed by this version of PHP iv heard of errors with the noew 5.x releases.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  7. #6
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Yeah...that should work, though that's really bad form there Giro.

    Code:
    vim /etc/portage/package.use
    dev-php/php -gettext
    <ESC> &#58;wq
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  8. #7
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    ug still having no luck, im gonna re-merge a few libs that have the word 'text' in them, but honestly, I have a feeling this is gonna be something stupid and simple.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  9. #8
    Linux Guru kkubasik's Avatar
    Join Date
    Mar 2004
    Location
    Lat: 39:03:51N Lon: 77:14:37W
    Posts
    2,396
    auuug, still no dice, I;ve posted a thread on the Gentoo forums, but no hits from that (to date) should anyone have any other ideas, do you think my gcc might be borked? I mean, no issues to date, but its possible i guess.... (yes, this isnt in the compile stage, but its possible that the defeault libs were not all installed correctly)

    any and all insight is appreciated.
    Avoid the Gates of Hell. Use Linux
    A Penny for your Thoughts

    Formerly Known as qub333

  10. #9
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    IIRC i havent used gentoo for a bit but to emerge PHP5 this should work

    Code:
    emerge ">php-5.0.1"

  11. #10
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    This bug report any good?

    http://bugs.php.net/bug.php?id=7259&edit=1
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •