Find the answer to your Linux question:
Results 1 to 3 of 3
I'm not too sure what happened in between or etc but my client started complaining that his server cannot resolve the domains hosted there. So naturally, I went to check ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Malaysia
    Posts
    1

    IPTABLES Gone Crazy


    I'm not too sure what happened in between or etc but my client started complaining that his server cannot resolve the domains hosted there. So naturally, I went to check and the funny thing is that after checking, I found out that PORT 53 has been blocked and thus I stopped the IPTABLES and everything went back to normal.

    The funniest thing is that everytime IPTABLES restarted, it would give the same error again. The domains there will not resolve. It seems that even after trying to add a rule to IPTABLES for PORT 53 to be unblocked, it would still do the same thing.

    Does anyone actually know or have encountered this problem before? My client is using CentOS and DirectAdmin. I've asked DA about this problem and they just told me to stop the IPTABLES which I do not think is a good solution.

    If anyone could help, it would be very much appreciated. I have found no errors on IPTABLES, the config and etc are all the DEFAULT settings and has not been changed. Plus, APF rules did state that port 53 be opened already.

    Please do help out if you have encountered this problem before. Thanks a lot!

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    is there/was there a dns server running on this machine, bind?

  3. #3
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    OK, if theis machine is on the internal network then you can stop IPTABLES as it should not really be needed. If the External WAN is connecting to this maching then IPTABLES should still be used.

    If you want to stop IPTABLES and ensure they are not started again automaicly then do the following:

    Code:
    service iptables stop
    chkconfig --level 2345 iptables off
    Sounds like this machine is rebooted and when it start it starts iptables automaticly.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •