Find the answer to your Linux question:
Results 1 to 6 of 6
dear All, i have configured the DNS server after restart the service i got this error, my.internal.zone.db:1: no TTL specified; using SOA MINTTL instead zone my.internal.zone/IN: loaded serial 1 slaves/my.ddns.internal.zone.db:1: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! abdul raziq's Avatar
    Join Date
    Dec 2006
    Location
    Quetta
    Posts
    74

    DNS Service Error


    dear All,

    i have configured the DNS server after restart the service i got this error,

    my.internal.zone.db:1: no TTL specified; using SOA MINTTL instead
    zone my.internal.zone/IN: loaded serial 1
    slaves/my.ddns.internal.zone.db:1: no TTL specified; using SOA MINTTL instead
    zone my.ddns.internal.zone/IN: loaded serial 1
    zone my.external.zone/IN: loading master file my.external.zone.db: file not found
    external/my.external.zone/IN: file not found


    any could help me

    Thanks

    Raziq

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,809
    Usually most distros these days come with DNS server already set up in a chroot jail. This means the service has it's own subset of the system outside of which it cant read.

    You've probably got your links or paths to your domain's zone files pointed to places that dont exist in the chroot.

    I suggest you go down the configured paths for your DNS domain and confirm that they point at the files and directories you expect.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined! pratapsingh's Avatar
    Join Date
    Feb 2009
    Posts
    82
    Can you just paste your db file configuration here i thnk u missed TTl value in that or u have just missplaced it ..

  4. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Quote Originally Posted by abdul raziq View Post
    my.internal.zone.db:1: no TTL specified; using SOA MINTTL instead
    zone my.internal.zone/IN: loaded serial 1
    slaves/my.ddns.internal.zone.db:1: no TTL specified; using SOA MINTTL instead
    zone my.ddns.internal.zone/IN: loaded serial 1


    The above messages are telling you that you did not configure your zone TTL's and it is going to use the minimum times for TTL's.

    The zone TTL's are located at the top of the zone, i.e.

    Code:
    $TTL    86400 ; 24 hours could have been written as 24h or 1d
    $ORIGIN example.com.
    @  1D  IN     SOA ns1.example.com.    hostmaster.example.com. (
                      2002022401 ; serial
                      3H ; refresh
                      15 ; retry
                      1w ; expire
                      3h ; minimum
    zone my.external.zone/IN: loading master file my.external.zone.db: file not found
    external/my.external.zone/IN: file not found


    This message is telling you that Bind cannot find the file you have configure in its configured directory. You should look at a few things here to figure out where you need to place my.external.zone file

    in named.conf look at the following lines to determine where the file should be placed

    Code:
    options {
      directory "/var/named"
    This statement tell bind where its working directory is. in this case it's /var/named but if your system is running Bind in a chroot env then the real path is /var/named/chroot/var/named

    You should also look at your zone definitions to ensure that they don't point Bind to another directory for the zone files. The file option is what you should be looking at.

    Code:
    zone "example.com" in{
      type master;
      file "master/master.example.com";
      // enable slaves only
      allow-transfer {192.168.23.1;192.168.23.2;);
    };
    In the above config it is telling Bind to look in the master directory for the file. This is really /var/named/master and if you are using the chroot env then it is the same as above with master at the end.

    Here is a link you could read for more information.
    If you like a book in the hand then I would highly recomend this O'Reilly book.

    any could help me

    Thanks

    Raziq
    Should you any more question please let us know.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  5. #5
    Just Joined! pratapsingh's Avatar
    Join Date
    Feb 2009
    Posts
    82

    Post

    zone "example.com" in{
    type master;
    file "master/master.example.com";
    // enable slaves only
    allow-transfer {192.168.23.1;192.168.23.2;
    };
    "master/master.example.com" Rename this file and
    name of this file should be like this "master.example.com.db" and create it under /var/named/ directory

    c ontent should be like this

    $TTL 86400 ; 24 hours could have been written as 24h or 1d
    ;$ORIGIN example.com. ; do not use this untill unless you dont know what is ;the use of this ..
    @ 1D IN SOA ns1.example.com. hostmaster.example.com. (
    2002022401 ; serial
    3H ; refresh
    15 ; retry
    1w ; expire
    3h ; minimum
    )


    And your serial number seems to be too big try to use small numbers ..
    still if you still facing any issue please paste it here again i will try to resolve

  6. #6
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Quote Originally Posted by pratapsingh View Post
    zone "example.com" in{
    type master;
    file "master/master.example.com";
    // enable slaves only
    allow-transfer {192.168.23.1;192.168.23.2;
    };
    "master/master.example.com" Rename this file and
    name of this file should be like this "master.example.com.db" and create it under /var/named/ directory

    c ontent should be like this

    $TTL 86400 ; 24 hours could have been written as 24h or 1d
    ;$ORIGIN example.com. ; do not use this untill unless you dont know what is ;the use of this ..
    @ 1D IN SOA ns1.example.com. hostmaster.example.com. (
    2002022401 ; serial
    3H ; refresh
    15 ; retry
    1w ; expire
    3h ; minimum
    )


    And your serial number seems to be too big try to use small numbers ..
    still if you still facing any issue please paste it here again i will try to resolve
    The above you have referenced is from an example config not the real thing.

    The file name you use can be anything you want to call it. it doesn't have to end in db.

    The serial number it is perfectly fine and is not too big. Allow me to explain.

    2002022401 ; serial is broken down as follows;

    2002 = year
    02 = month
    24 = day
    01 = number of changes that day.

    This is used for auditing purposes and is followed by many.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •