Find the answer to your Linux question:
Results 1 to 4 of 4
I just did a Debian 5.0 network install all went fine I installed bind9 using the following guide Configuring bind9 in a chroot, lenny version - Blog I changed the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    1

    bind won't start now :(


    I just did a Debian 5.0 network install all went fine

    I installed bind9 using the following guide Configuring bind9 in a chroot, lenny version - Blog

    I changed the forwarders to what I wanted them to be, all worked internally (LAN)

    Configured a one-to-one NAT for a free public IP address we had and opened DNS on our SonicWALL to allow an external connection. Here is where things started breaking. I continued messing with the SonicWALL firewall rules and opened it wide open to the internal IP. I then thought iptables was blocking it so I did apt-get remove iptables and rebooted.

    Now when I rebooted, bind won't start at all, when I do /etc/init.d/bind9 status it says

    bind9 is not running failed!

    So everything was working fine until I removed iptables and rebooted. Below are some things that hopefully will help.

    /etc/hosts

    Code:
    127.0.0.1       localhost
    192.168.1.231   server01
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    /etc/resolv.conf
    Code:
    nameserver 127.0.0.1
    /etc/bind/named.conf
    Code:
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
    
    include "/etc/bind/named.conf.options";
    
    // prime the server with knowledge of the root servers
    zone "." {
            type hint;
            file "/etc/bind/db.root";
    };
    
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
    
    zone "localhost" {
            type master;
            file "/etc/bind/db.local";
    };
    
    zone "127.in-addr.arpa" {
            type master;
            file "/etc/bind/db.127";
    };
    
    zone "0.in-addr.arpa" {
            type master;
            file "/etc/bind/db.0";
    };
    
    zone "255.in-addr.arpa" {
            type master;
            file "/etc/bind/db.255";
    };
    
    include "/etc/bind/named.conf.local";
    /etc/bind/named.conf.local
    Code:
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    /etc/bind/named.conf.options
    Code:
    options {
            directory "/var/cache/bind";
    
            // If there is a firewall between you and nameservers you want
            // to talk to, you may need to fix the firewall to allow multiple
            // ports to talk.  See http://www.kb.cert.org/vuls/id/800113
    
            // If your ISP provided one or more IP addresses for stable
            // nameservers, you probably want to use them as forwarders.
            // Uncomment the following block, and insert the addresses replacing
            // the all-0's placeholder.
    
             forwarders {
                    <external IP>;
                    <external IP>;
             };
    
            auth-nxdomain no;    # conform to RFC1035
            listen-on-v6 { any; };
    };

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    Have you tried to start bind manually?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined! pratapsingh's Avatar
    Join Date
    Feb 2009
    Posts
    82
    Hi did you check your log then paste it here . And i think its because of your iptables.

  4. #4
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,672
    IPTABLES is not going top stop Bind from starting.
    Most likely the server got turned of from starting.
    This could have happened long before the reboot or removal of IPTABLES.
    In the future just turn off the server. No need to remove it.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •