Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
ahh, that may be the problem. did you configure ssl on the server or have you not done anything beyond installing? it sounds like apache is configured to server ssl ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077

    ahh, that may be the problem. did you configure ssl on the server or have you not done anything beyond installing? it sounds like apache is configured to server ssl with a certificate that requires a passphrase, so when you boot the computer up there is no place to prompt for a passphrase so it just rolls right over it and you get a defunct apache. a simple test would be to disable starting the 443 port in your conf file and removing any 443 virtual hosts and then try it again

  2. #12
    Just Joined!
    Join Date
    Mar 2008
    Posts
    21
    Yes, I did do some configuring of my ssl certificate after the install. As I understand this is to allow my displaying of a default webpage.
    So, I did as you suggested

    I looked at my conf file, (apache2.conf) there is no mention of SSL or port 443 there, so that went untouched.
    In my "sites-enabled" directory, I removed the symbolic link to the default-ssl that is in sites-available, then I commented out port 443 in /etc/apche2/ports.conf
    Rebooted, then did a netstat, this showed apache listening on port 80.
    The stopping and starting of apache now works fine without errors.
    I tried displaying the webpage using "http://localhost" and it works fine, how do I get to this page from another pc?
    Last edited by jimf; 04-19-2009 at 02:50 AM. Reason: update

  3. #13
    Just Joined!
    Join Date
    Mar 2008
    Posts
    21

    Solved!

    Apache2 now starting and stopping normally.

    Thanks guys for your help.

    I'll persure the question "how does one get to load a page from another cpmputer"
    after I do research.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    Now thats really good to hear!
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •