Find the answer to your Linux question:
Results 1 to 7 of 7
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    BIND Problems, please help!

    Hi everyone, I have a Mandrake 10.0 machine with BIND installed.

    I have followed the DNS how to located at
    and found it very useful.

    I have performed the dig -x command and get everything as the how to says I need.

    But when I run nslookup on the Windows clients :

    DNS request timed out.
    timeout was 2 seconds.
    *** Can't find server name for address Timed out
    DNS request timed out.
    timeout was 2 seconds.
    *** Can't find server name for address Timed out
    DNS request timed out.
    Default Server: UnKnown

    What have I done wrong?

    Please help.


  2. #2
    Does ping from the windows clients work?


  3. #3
    Yes ping works fine

  4. $spacer_open
  5. #4 is the IP address of the Linux machine that I have DNS running on.

    I am trying to run nslookup on my Windows XP client and I get ;

    *** Can't find server name for address No response from server
    DNS request timed out.

    I have the default config for named that has the root zone and the 127.0.0 which has the reverse zone already entered (as per default)

    I also selected "" as my machines full domain name as thats how I wanted it set up when I got DNS going

    I tried reading the DNS HOW-TO but couldn't get my head around it. I have been using webmin to do what I have done so far and I find that a lot more practical than manually modifying configs

    I am very new to Linux but I am doing a course in networking at university so I know the basics just can't understand how to apply them to this.

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Cambridge, UK
    i have the exact same issue... i've already postted here:

    and here:

    but nothing so far... please feel free to read one of those topics though, to ensure they are the same issue as this one...

    did you ever find a solution?

  7. #6
    a firewall or gateway issue preventing the lookup ?

  8. #7
    Just Joined!
    Join Date
    Feb 2004
    have you put your name server on

    * /etc/resolv.conf
    domain (change domain like what you want)
    nameserver (you have NIC ok - i set like this on my Comp.)

    * /etc/hosts.conf
    #this commonly on /etc/hosts.conf
    hosts,bind (this meat that nameserver will lookup /etc/hosts and then nameserver BIND

    * /etc/hosts
    # default installation don't remove at localhost localhost.localdomain localhost jupiter (computer named jupiter) mars (computer named mars)

    double check files at /etc/resolv.conf if intall by default installation it must be servername file at /var/named, make sure you have it at least what you mean like

    /var/named/ --- (or whatever you named it just OK)

    check on /var/named/ is it reflecting about what you needed ?

    after all let's do like RH behaviour

    /etc/rc.d/init.d/named start

    check on

    #tail -f /var/log/messages
    make sure you don't have any mistakes

    and ping it should you have a reply or do
    # dig

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts