Find the answer to your Linux question:
Results 1 to 3 of 3
I have installed BerkeleyDB 4.7 and I'm now trying to install OpenLDAP-2.4.16. Here's what I've done (after installing BerkeleyDB) to get to the point where I can run "make test": ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    2

    LDAP make test hangs


    I have installed BerkeleyDB 4.7 and I'm now trying to install OpenLDAP-2.4.16.

    Here's what I've done (after installing BerkeleyDB) to get to the point where I can run "make test":
    export CPPFLAGS="-I/usr/local/BerkeleyDB.4.7/include"
    export LDFLAGS="-L/usr/local/lib -L/usr/local/BerkeleyDB.4.7/lib -R/usr/local/BerkeleyDB/lib"
    export LD_LIBRARY_PATH="/usr/local/BerkeleyDB.4.7/lib"

    Following:
    ./configure
    make depend
    make
    "make test" hangs with the last few lines saying:
    >>>>> Starting test001-slapadd ...
    running defines.sh
    Running slapadd to build slapd database...

    Grasping at straws (I'm a Linux newb just installing this with a view to get cURLpp going but need to compile everything first as it's going to be on an embedded system after getting it going under Ubuntu 8.04) I searched for solutions and tried:

    Copy the BerkeleyDB install files into /usr/local/ and then try again, doing:
    cd /usr/local/BerkeleyDB.4.7
    cp -rd . ..
    cd /home/mm6/openldap-2.4.16
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
    ./configure
    make depend
    make

    But "make test" still hangs in the same place.

    The easy way might be to get a package and install that but as I will need to rebuild everything for an embedded system this is not an option.

    Any help greatly appreciated.
    Thank you.

  2. #2
    Just Joined!
    Join Date
    May 2009
    Posts
    1

    make test Hangs in openldap installation

    hi,

    I am having the same problem as you have when i am giving make test
    its waiting on

    Running slapadd to build slapd database...

    and i am not able to continue to for installation.

    plz tell me if you find any solution for that.

    As i am guessing that you might get it solved as u posted it one month before...


    Thanks in advance

    Visu

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    2

    No solution yet.

    I thought I needed this for dependancies of cURLpp but this does not seem to be the case. Unless I'm wrong then this is not so urgent for me but I would still like to know the solution to help Visu (and so I can perhaps learn a bit more too).

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •