Find the answer to your Linux question:
Results 1 to 5 of 5
hi i'v been struggling with samba for sometime, and i have it working somewhat, i'm haveing a problem with ubuntu 8.04 rembering my password for samba. how i got it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! klein's Avatar
    Join Date
    Nov 2008
    Posts
    8

    samba forgets password ubuntu 8.04


    hi
    i'v been struggling with samba for sometime, and i have it working somewhat, i'm haveing a problem with ubuntu 8.04 rembering my password for samba.

    how i got it working is i gave every computer an static ip and i shared my /home/klein/ dir in nautilus, nautilus installed samba when i shared the file, i changed the share name to kleinlg1.
    then in terminal i did sudo smbpasswd -a klein then sudo /etc/init.d/samba restart.
    i did the same thing to the other computer, just changed the share name to kleinxgen2 and the password is different.
    it works great till a reboot or you go to another share on another computer. i also created a desktop launcher and used this as a command smb://192.168.1.33/kleinxgen2/ and it will bring up the password box,
    at this point it comes back with wrong password !!!!!!!!!!! ger ok if i go to the computer i'm trying to connect to and in terminal and do sudo smbpasswd -a klein and retype the same password twice the share will open!!!!!!!!!!!!!!! you don't have to do a samba restart at all.

    ok i have 7 computers on one linksys switch, all are set up this way and all have the same problem lol
    computers are devided between two kvm switches witch doesn't matter, the only thing is i can sit here and work and watch what is happening, so the only problem i have is the computer i'm trying to connect to doesn't remember it's password. i have not changed anything in the samba config file, mainly because i don't know what to change. i believe i'm running samba 4.7?
    thank for any help in advance

  2. #2
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    -a option for smpasswd is to adduser.
    use command.
    # smbpasswd -U username
    Then change the password.
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

  3. #3
    Just Joined! klein's Avatar
    Join Date
    Nov 2008
    Posts
    8
    hi
    thanks i have them all working except one computer if i try opening the share from my laptop i use the samba pass word and not the user pass word but it works.

  4. #4
    Linux Engineer b2bwild's Avatar
    Join Date
    Jul 2008
    Location
    Behind You!
    Posts
    1,108
    Samba authonticates using user's samba password.
    Mostly people keep user password and samba password same.
    Never make any misteaks.

    Read my Blog at --> Penguin Inside Subscribe Feed

  5. #5
    Just Joined!
    Join Date
    Aug 2009
    Posts
    1

    I fixed the same problem!

    On a hunch, I did smbpasswd from the lost user in question, and my _shell_ password was the correct old password!

    Then I remembered and changed to No this option in smb.conf:

    # This boolean parameter controls whether Samba attempts to sync the Unix
    # password with the SMB password when the encrypted SMB password in the
    # passdb is changed.
    unix password sync = no

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •