Find the answer to your Linux question:
Results 1 to 5 of 5
I'm trying to connect to a database I made on a linux box using mysqladmin from XP. When I try to login as root I get this error. Code: MySQL ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2009
    Posts
    2

    Question [SOLVED] mysqladmin connection error


    I'm trying to connect to a database I made on a linux box using mysqladmin from XP.

    When I try to login as root I get this error.
    Code:
    MySQL Error Number 1045
    Access Denied for user 'root' at 'myip' (using password: NO)
    There is no root password setup. (at least i think there isn't based on this)
    Code:
    $ mysql -u root
    Welcome to the MySQL monitor. ...
    mysql>
    I've already ran a GRANT ALL ... command if that makes any difference here

    Any help would be appreciated

  2. #2
    Linux User
    Join Date
    May 2008
    Location
    NYC, moved from KS & MO
    Posts
    251
    Not sure how your grant command looks like, but if you want to enable access for user root from <xp_ip>, you would have to execute the following mysql commands on the server after logging in with user root:
    Code:
    grant all on *.* to 'root'@'<xp_ip>' identified by '<password>';
    flush privileges;
    Substitute <xp_ip> and <password> with your xp's ip and the password you want.

  3. #3
    Just Joined!
    Join Date
    Jul 2009
    Posts
    7
    Hi Wsetchell, You might have forgot to give access to IP in that SQL string. try above SQL query if that doesnt work then make sure that port 3306 is open in your firewall.

    Good Luck.

  4. #4
    Linux User
    Join Date
    May 2008
    Location
    NYC, moved from KS & MO
    Posts
    251
    make sure that port 3306 is open in your firewall
    I don't think firewall is the problem here since the reply message
    MySQL Error Number 1045
    Access Denied for user 'root' at 'myip' (using password: NO)
    is from mysql server, meaning if you are not connected to the mysql server, you would not have seen that error at all.

  5. #5
    Just Joined!
    Join Date
    Jun 2009
    Posts
    2
    Quote Originally Posted by secondmouse View Post
    grant all on *.* to 'root'@'<xp_ip>' identified by '<password>';
    flush privileges;
    Substitute <xp_ip> and <password> with your xp's ip and the password you want.
    This fixed my problems. Thanks everyone

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •