Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Sendmai, SMART_HOST, and MX Records. Oh my!

    Is there some way to make sendmail disregard MX record when sending to a SMART_HOST?

    The issue is we have our main mail cluster, named mxhost1. It is the MX host in dns for all internal systems.

    We have a special one for some of the system called mxhost3. On some hosts we specify mxhost3 as the SMART_HOST.

    On the special servers I run "sendmail -bv someemailaddress". It returns that it will relay through mxhost3.

    Here is where the problem comes up. Rather than go off the SMART_HOST setting exclusively, sendmail sees that mxhost1 is the MX host for mxhost3.

    Is this expected behavior? This cost me several hours today debugging this and it seems like a silly thing to essentially over ride the SMART_HOST setting.

  2. #2
    Linux Guru Lakshmipathi's Avatar
    Join Date
    Sep 2006
    3rd rock from sun - Often seen near moon
    I'm not sure whether i understood your problem correctly,
    If you want to use mxhost3 as SMART_HOST try the following
    1) Make sure local sendmail port 25 is not blocked & Add ip address of remote machine in /etc/hosts file
    #vi /etc/hosts xxxcomdev

    2) In provide your sendmail server name and make sure DAEMON_OPTIONS is commented,

    #vi /etc/mail/


    dnl DAEMON_OPTIONS(`Port=smtp,Addr=, Name=MTA')dnl

    3)creat new configuration file using following command,
    #m4 >

    4)Restart the sendmail program.
    #service sendmail restart
    First they ignore you,Then they laugh at you,Then they fight with you,Then you win. - M.K.Gandhi
    FOSS India Award winning ext3fs Undelete tool Online Linux Terminal

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts