Find the answer to your Linux question:
Results 1 to 3 of 3
...Or I think samba. There is a server on my school network called "OAK" on a windows lab computer, I can simply map a network drive to "\OAK\home" When I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    1

    Samba


    ...Or I think samba. There is a server on my school network called "OAK" on a windows lab computer, I can simply map a network drive to "\\OAK\home" When I look at the settings and whatnot, it says that my username "me AT subdomain DOT school DOT edu" has permissions to access the drive. After I connect it says "Linux Home Directory Server" so that's how I know it's a linux box...
    I would like to be able to somehow connect to it from my own computer (which is Running OS X, but I just want to be able to connect from the command line). I can attempt to ssh into it, but it always rejects me.

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,844
    This kind of login has probably been disabled on the server, if you're not meant to log in that way.

    Talk to the system administrators and find out what services you can use - ssh should be the standard to use, but they may have password-based access turned off, and it'd require keys to login. If you're allowed access they'll help you generate them and make sure you get a copy of the public key you'd need.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    46
    on OSX, try cmd+k (cmd is also known as the Apple key.) (or Finder -> 'Go' menu -> 'Connect to Server...' at the bottom)

    this should bring up a "connect to server" prompt. try using 'smb://server.address.edu' or whatever. if this works, you should get to a password screen. try a few variants on your username (maybe include @domain) and see if you can get in.

    FYI: ssh != samba. at all. entirely different protocols on entirely different ports, often running entirely different user/password systems.

    on the commandline, you might want to try 'man smbclient.' I've used it a few times but really hate it since it requires a whole bunch of backslashes to properly format the user, domain, server and mount point. it looks like OSX also has 'smbclient', but why do that when you have a nice system tool built-in?

    good luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •