Find the answer to your Linux question:
Results 1 to 2 of 2
Hi Everybody. I've finished my squid install today, but i've an strange issue. When i look at / var/log/squid3/cache.log i've this message : Code: 2009/07/29 16:07:31| storeDirClean: /var/spool/squid3/05/E6: (13) Permission ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    1

    squid error user rights issue ??


    Hi Everybody.

    I've finished my squid install today, but i've an strange issue.

    When i look at /var/log/squid3/cache.log i've this message :

    Code:
    2009/07/29 16:07:31| storeDirClean: /var/spool/squid3/05/E6: (13) Permission denied
    When i do a sudo /etc/init.d/squid3 restart, i've no error message but only the tag [FAIL].

    the rights on the /var/spool/squid3 folder are assigned to the squid user ( owner too ).

    In my squid.conf i've wrote :

    cache_effective_user squid
    cache_effective_group squid


    I've tried in removing the both code ligne, but i've the same issue.
    I've tried a chmod 777 on the /var/spool/squid3 folder but nothings happens.

    I've stopped squid service, deleter the content of /var/spool/squid3 folder and restarted squid service but ever the same issue.

    Then now...i don't know what to do to resolve this issue except trying to totally remove squid an setup it again from scratch.


    If someone encounter this issue or know a way to resolve it...i'll be really appreciated.

  2. #2
    Just Joined!
    Join Date
    Jul 2009
    Posts
    58
    From what it sounds like you did the right test steps, so try this:

    # id squid

    make sure squid exists as a user and belongs to the squid group

    As root
    # su - squid
    As someone with sudo
    # sudo -u squid -s -H

    # cd /var/spool/squid3
    # touch foo
    # mkdir -p t1/t2

    See if either one of those gives you an error.

    If so `ls -lR /var/spool/squid3` and post the output.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •